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Introduction 

Photoshop offers many graphics tools for Web developers. This workshop’s focus it to 

demonstrate Adobe's companion product for creating Web ready images; ImageReady. 

ImageReady offers powerful Web features for optimizing, slicing, creating rollovers as 

well as GIF animation. 

Objectives 

Maximize productivity producing graphics for the World Wide Web using the following: 

• Optimize your image file type and file size. 

• Use slicing tools to increase image/Web page load times. 

• Create interactive navigation buttons using image rollovers. 

• Animate GIF images to use on a Web page. 

Prerequisites 

Photoshop Introduction or equivalent skills. 

Related Training Available from ACS 

All workshops offered by Instructional Services are free to KU students, staff, faculty, 

and approved affiliates. 

To learn more about or register for workshops, receive automatic announcements of 

upcoming workshops, and track workshops you’ve registered for and have attended, visit 

www.lib.ku.edu/instruction/workshops. For further workshop related questions, please 

email training@ku.edu. 

Web Graphic File Types 

There are three main file types for image files standardized by the World Wide Web 

Consortium (W3C): GIF, JPEG and PNG. Each is unique and each has distinct 

advantages and disadvantages. 

GIF Image File Format 

GIF images are a compact way of delivering graphic data over a network. Because of the 

limited pallet (256 colors) the GIF format is better suited for simple text logos, buttons, 

bullets and graphic lines. 

Indexed Color 

GIF images are essentially a matrix of index values pointing at a table of colors which 

can contain up to 256 values, allowing each color in a bitmap (the matrix) to be 

represented in at most 1 byte. 

GIF (and JPEG) is "lossy," meaning that the decompressed image isn't quite the same as 

the one you started with. The millions of colors available in a typical real world image 
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need to be redefined to conform to the much reduced color set available in an indexed 

representation. This reduction of the number of colors contributes to the compression 

achieved with GIF. 

JPEG Image File Format 

JPEG (pronounced "jay-peg") is a standardized image compression mechanism.  

JPEG is designed to compress full-color or gray-scale images of natural, real-world 

scenes.  It works well on photographs, naturalistic artwork, and similar material; not so 

well on lettering, simple cartoons, or line drawings.  JPEG handles only still images, but 

there is a related standard called MPEG for motion pictures. 

JPEG is designed to exploit known limitations of the human eye, notably the fact that 

small color changes are perceived less accurately than small changes in brightness.  Thus, 

JPEG is intended for compressing images that will be looked at by humans.  If you plan 

to machine-analyze your images, the small errors introduced by JPEG may be a problem 

for you, even if they are invisible to the eye. 

JPEG images have a 16-bit color palette allowing up to 16.7 million colors in one image. 

This format is highly compressible (ie. large images can be squeezed into small amounts 

of memory) which makes it ideal for use on the Internet. The amount of compression can 

be adjusted to achieve the desired trade-off between file size and visual quality.  

Progressive JPEG is a means of reordering the information so that, after only a small part 

has been downloaded, a hazy view of the entire image is presented rather than a crisp 

view of just a small part. Progressive JPEG is now widely supported. 

PNG Image File Format 

The initial motivation for developing PNG graphics was to replace GIF with something 

better. The design of PNG goes further than GIF and adds many new features. PNG is a 

loss less format, which means that when the image is decompressed, the exact original 

pixel values are preserved. PNG graphics also support true color in addition to indexed 

color, whereas only the latter is supported by GIF (so GIF is lossy for True Color 

images). In True Color, RGB (and optionally, alpha) values for each pixel are specified 

directly, while indexed color represents each pixel as an entry in a palette. Using True 

color greatly enhances graphical quality, dispenses the need for palettes, and is also 

invaluable when an image has variable levels of transparency. 
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Optimizing Web Graphics 

Optimization is the process of fine-tuning the display quality and file size of an image for 

use on the Web or other online media. There are many controls for compressing the file 

size of an image while optimizing its online display quality. You can optimize images in 

the three major graphic file formats used on the Web: 

There are two methods of optimizing images: 

For basic optimization, the Save As command lets you save an image as a GIF, JPEG, or 

PNG file. Depending on the file format, you can specify image quality, background 

transparency or matting, color display, and downloading method. However, any Web 

features--such as slices, links, animations, and rollovers--that you've added to a file are 

not preserved. 

For precise optimization, you can use the Save for Web (Photoshop) or Save Optimized 

(ImageReady) command to preview optimized images in different file formats and with 

different file attributes. You can view multiple versions of an image simultaneously and 

modify optimization settings as you preview the image.  It manner you can select the best 

combination of settings for your needs. You can also specify background transparency 

and matting, select options to control dithering, and resize the image to specified pixel 

dimensions or a specified percentage of the original size. 

 

When you save an optimized file using the command, you can choose to generate an 

HTML file for the image. This file contains all the necessary code to display your image 

as well as links, rollovers, and animations in a Web browser. 
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Using Graphical Slices 

You use slices to divide a source image into functional areas. When you save the image 

as a Web page, each slice is saved as an independent file that contains its own settings, 

color palette, links, rollover effects, and animation effects. You can use slices to achieve 

faster download speeds. Slices are also advantageous when working with images that 

contain different types of data. For example, if one area of an image needs to be 

optimized in GIF format to support an animation, but the rest of the image is better 

optimized in JPEG format, you can isolate the animation using a slice. 

Viewing Slices 

Slice lines define the boundary of the slice. Solid lines indicate that the slice is a user-

slice or layer-based slice; dotted lines indicate that the slice is an auto-slice.  

Slice colors Differentiate user-slices and layer-based slices from auto-slices. By default, 

user-slices and layer-based slices have blue symbols, while auto-slices have gray 

symbols.  

Slice numbers - Slices are numbered from left to right and top to bottom, beginning in 

the upper left corner of the image. If you change the arrangement or total number of 

slices, slice numbers are updated to reflect the new order.  

Slice symbols - Indicate whether a user-slice is an Image  or No Image  slice; if the 

slice is a layer-based slice ; if the slice is linked ; or if the slice includes a rollover 

effect . 

Show or Hide slices 

In order for slices to be displayed you need to turn on display of slices in the View > 

Show submenu, and ensure the choose View > Show Extras option is checked.  

Click the Slices Visibility button  on the Tool Box. 

Change the display of slices 

1. Choose Edit > Preferences > Slices.  

2. Under Numbers and Symbols, 

select a size for display 

symbols: 

• None to display no 

numbers or symbols.  

• The small icon to display 

small numbers and 

symbols.  

• The large icon to display 

large numbers and 

symbols.  

3. For Opacity, enter a value, or choose a value from the pop-up slider to change the 

opacity of the numbers and symbols display.  
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4. Enter a value, or choose a value from the Color Adjustments pop-up slider for 

User-slices, Auto-slices, or both. (The User-slices option controls color 

adjustments for both user-slices and layer-based slices.) 

• The value determines by how much the brightness and contrast of unselected 

slices are dimmed.  

Working with Slices 

To select a slice: 

1. Select the slice select tool . 

2. Click on a slice in the image. When working with overlapping slices, click the 

visible section of an underlying slice to select it.  

Note: To toggle between the slice tool and the slice select tool, hold down 

Ctrl (Windows) or Command (Mac OS). 

To select multiple slices 

With the slice select tool , do one of the following: 

1. Shift-click to add slices to the selection.  

2. You can save, load, and delete slice selections. 

Using slice selections lets you reselect specific slices 

quickly and accurately.  

To save a slice selection 

1. Select one or more slices. 

2. Choose Slices > Save Slice Selection. 

3. Enter a name in the Selection Name text box, and 

click OK. 

To load a slice selection 

Choose Slices > Load Slice Selection, and select the name 

of the slice selection you want to load from the submenu.  

To delete a slice selection 

Choose Slices > Delete Slice Selection, and select the name 

of the slice selection you want to delete from the submenu. 

Deleting a slice selection does not delete the slices 

themselves.  

You can create user-slices with the slice tool , and in 

ImageReady, from a selection or from guides. 
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To create a slice with the slice tool 

1. Select the slice tool . Any existing slices 

automatically display in the document 

window.  

2. Choose a style setting in the options bar: 

• Normal to determine slice proportions 

by dragging.  

• Constrained Aspect Ratio to set a height-to-width ratio. Enter whole 

numbers or decimals for the aspect ratio. For example, to create a slice twice 

as wide as it is high, enter 2 for the width and 1 for the height.  

• Fixed Size to specify the slice's height and width. Enter pixel values in whole 

numbers.  

3. Drag over the area where you want to create a slice. Shift-drag to constrain the 

slice to a square. Use snap to align a new slice to a guide or another slice in the 

image. 

To create a slice from a selection 

1. Select a portion of the image using an option from the marquis tool such as   

2. Choose Select > Create Slice from Selection. 

Note:    User-slices are created based on the Selection marquee. If the selection is 

feathered, the slice covers the full selection (including the feathered edges). 

 

If the selection is nonrectangular, the slice covers a rectangular area large 

enough to cover the full selection. 

Optimizing Slices 

All Image slices use the optimization settings of the entire image until you apply new 

settings. If you select multiple slices with different optimization settings, only the 

controls that are relevant to all of the selected slices are visible. If settings for a control 

differ among slices, the control is blank. Any settings you choose are applied to all 

selected slices.  

You can also copy optimization settings from one slice to another within a document, or 

from a slice in one view to a slice in another view in 2-Up or 4-Up view. 

To optimize a slice 

Select one or more Image 

slices, and specify options 

in the Optimize 

panel/palette. 

To copy optimization 

settings between slices: 
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Select the slice that uses the optimization settings you want to copy. 

Drag the Droplet icon  from the Optimize palette onto the slice to which you want to 

apply the optimization settings. 

Image Rollovers 

A rollover is a Web effect in which different states of an image appear when a viewer 

performs a mouse action, such as rolling or clicking over an area of the Web page. A 

state is defined by a specific configuration of the Layers palette, including layer location, 

styles, and other formatting options. 

You use a slice or image map area to define the active area for a rollover. By default, 

every slice or image map area has one state; the Normal state. (The Normal state 

corresponds to the appearance of an image when it is first loaded into a Web browser and 

no rollover effects have occurred.) When you add a new state to the rollover, you capture 

a snapshot of the slice or image map area in the previous state. You can then use the 

Layers palette to make changes to the image in the new state. 

Create Image Rollovers 

When you create a rollover state, you select a mouse action that activates the state (except 

for the first state in a rollover, which is always the Normal state).  

To create a rollover state 

1. Select the slice or image map area to which you want to add the rollover.  

Note: When creating a slice or image map area for a rollover, use a layer-

based slice or a layer-based image map area. This is recommended 

because the dimensions of a layer's content may change in the course 

of creating a rollover. 

2. In the Web Content palette (Window>Web Content), create a new state: 

• Click the Create Rollover State button  at the bottom of the palette. 

 



Instructional Services 

Photoshop:  Web Graphics 

Instructional Services at KU Libraries - 9 - © 2007 The University of Kansas 
A Division of Information Services 

The new rollover state is identical to the state immediately preceding it, until you make 

modifications to the image using the Layers palette. 

3. Use the default rollover state, or to select a rollover state, in the Web Content 

window right click on the image visible under the Rollover State label: 

• Over defines the rollover state 

when the Web viewer rolls over the 

slice or image map area with the 

mouse while the mouse button is 

not pressed. (Over is automatically 

selected for the second rollover 

state.) 

• Down to define the rollover state 

when the Web viewer presses the 

mouse button on the slice or image 

map area. (This state appears as 

long as the viewer keeps the mouse 

button pressed down on the area.) 

• Out to define the rollover state 

when the Web viewer rolls the 

mouse out of the slice or image map 

area. (The Normal state usually 

serves this purpose.) 

• Up to define the rollover state when 

the Web viewer releases the mouse 

button over the slice or image map 

area. (The Over state usually serves this purpose.) 

• Click to define the rollover state when the Web viewer clicks the mouse on 

the slice or image map area. (This state appears after the viewer clicks the 

mouse and remains until the viewer activates another rollover state.) 

Note: Note: Different Web browsers, or different versions of a browser, may 

process clicks and double-clicks differently. For example, some 

browsers leave the slice in the Click state after a click, and in the Up 

state after a double-click; other browsers use the Up state only as a 

transition into the Click state, regardless of single- or double-clicking. 

To ensure your Web page will function correctly, be sure to preview 

rollovers in various Web browsers. 

• Custom to define a new rollover state. (You must create JavaScript code and add 

it to the HTML file for the Web page in order for the Custom rollover option to 

function. See a JavaScript manual for more information.) 

• None to preserve the current state of the image for later use as a rollover state. (A 

state designated as None will not be displayed on the Web page.) 

The Rollover States pop-up menu displays only the rollover states that have not yet 

been used for the selected slice or image map area (with the exception of the None and 

Custom states, which are always available and can be used repeatedly). You can redefine 

rollover states as you work (with the exception of the Normal state). 
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4. Modify the image for the rollover state using the Layers palette. 

Previewing rollover states 

You can preview rollover states directly in the document window by clicking on the 

Preview Document  tool in the tool box. This preview is consistent with Internet 

Explorer version 5.0 for Windows. To preview the rollover effect in your computer's 

default Web browser, click the Preview in Default Browser button in the toolbox.  

To use rollover preview mode 

1. Click the Rollover Preview button  in the toolbox. 

2. In the document window, perform the action that activates the rollover state. For 

example, position the mouse over the rollover slice or image map area to preview 

the Over state. Then click the slice or image map area to preview the Click state. 

To exit rollover preview mode 

Select any tool in the toolbox (including the Rollover Preview button), or click the Play 

button in the Rollover palette. 

Preview in Browser 

You can open a browser and preview an optimized image. You can preview the image in 

any browser installed on your system. The browser displays the image with a caption 

listing the image's file type, pixel dimensions, file size, and compression specifications in 

the first paragraph, and filename and other HTML information in the second paragraph.  

Upon installation, all browsers currently on your system are added to the Preview In 

menu. You can add additional browsers to the menu, and specify which browser will be 

launched when using a keyboard shortcut. 

To preview an optimized image in a browser 

Do one of the following: 

In Photoshop choose File > Save for Web, then select a browser from the Preview In 

button at the bottom right area of the Save for Web window.  

In ImageReady: 

• Choose File > Preview In, then choose an option from the submenu. (Choose 

Other to select a browser not listed in the submenu.) 

• Select a browser from the Preview in Default Browser tool in the toolbox. 

To add a browser to the Preview In menu 

1. Create a shortcut (Windows) or an alias (Mac OS) for the browser you want to 

add to the menu. 

2. Drag the icon for the shortcut or alias into the Preview In folder, located in the 

Helpers folder in the Photoshop program folder. 

3. Restart program to view the browser in the Preview In menu.  
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Web Animations 

An animation is a sequence of images, or frames, that are displayed over time. Each 

frame varies slightly from the preceding frame, creating the illusion of movement when 

the frames are viewed in quick succession. 

Working with layers is an essential part of creating animations. Placing each element of 

an animation on its own layer enables you to change the position and appearance of the 

element across a series of frames, using the Layers palette commands and options. 

The Animation palette lets you create, view, and set options for the frames in an 

animation. You can change the thumbnail view of frames in the Animation palette--using 

smaller thumbnails reduces the space required by the palette and displays more frames in 

a given palette width. 

To Insert a Second Frame  

Select the  option in the lower right corner of the Animation palette. Use the Layers 

palette to change the appearance of the second frame to create the illusion of motion. 

Tween Frames 

You use the Tween command to automatically add or modify a series of frames between 

two existing frames--varying the layer attributes (position, opacity, or effect parameters) 

evenly between the new frames to create the appearance of movement. For example, if 

you want to fade out a layer, set the opacity of the layer in the starting frame to 100%; 

then set the opacity of the same layer in the ending frame to 0%. When you tween 

between the two frames, the opacity of the layer is reduced evenly across the new frames. 

The term "tweening" is derived from "in betweening," the traditional animation term used 

to describe this process. Tweening significantly reduces the time required to create 

animation effects such as fading in or fading out, or moving an element across a frame. 

You can edit tweened frames individually after you create them. 
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Create frames with tweening 

1. To apply tweening to a specific layer, 

select it in the Layers palette. 

2. Select a single frame or multiple 

contiguous frames. 

If you select a single frame, you choose 

whether to tween the frame with the 

previous frame or the next frame. If you 

select two contiguous frames, new frames 

are added between the frames. If you 

select more than two frames, existing 

frames between the first and last selected 

frames are altered by the tweening 

operation. If you select the first and last 

frames in an animation, these frames are 

treated as contiguous, and tweened frames 

are added after the last frame. (This 

tweening method is useful when the 

animation is set to loop multiple times.) 

3. Do one of the following: 

• Click the Tween button  in the Animation palette. 

• Select Tween from the Animation palette menu. 

4. Specify the layer or layers to be varied in the added frames: 

• All Layers to vary all layers in the selected frame or frames.  

• Selected Layer to vary only the currently selected layer in the selected frame or 

frames.  

5. Specify layer attributes to be varied: 
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• Position to vary the position of the layer's content in the new frames evenly 

between the beginning and ending frames. 

• Opacity to vary the opacity of the new frames evenly between the beginning and 

ending frames. 

• Effects to vary the parameter settings of layer effects evenly between the 

beginning and ending frames. 

 

6. If you selected a single frame in step 2, choose where to add frames from the Tween 

With menu: 

• Next Frame to add frames between the selected frame and the following frame.  

• First Frame to add frames between the last frame and first frame. This option is 

only available if you select the last frame in the Animation palette. 

• Previous Frame to add frames between the selected frame and the preceding 

frame. 

• Last Frame to add frames between the first frame and last frame. This option is 

only available if you select the first frame in the Animation palette. 

7. Enter a value, or use the Up or Down Arrow key to choose the number of frames to 

add. (This option is not available if you selected more than two frames. In this case, 

the tweening operation alters the existing frames between the first and last frames in 

the selection.) 

8. Click OK. 
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Delay for frames 

You can specify a delay, the time that a frame is displayed, for single frames or for multiple 

frames in an animation. Delay time is displayed in seconds. Fractions of a second are 

displayed as decimal values. For example, one-quarter second is specified as .25. 

To specify a delay time: 

1. Select one or more frames. 

2. In the Animation palette, click on the Delay value 

below the selected frame to view the Delay pop-up 

menu. 

3. Specify the delay: 

• Choose a value from the pop-up menu. (The 

last value used appears at the bottom of the 

menu.) 

• Choose Other, enter a value in the Set Frame 

Delay dialog box, and click OK.  

If you selected multiple frames, specifying a delay value 

for one frame applies the value to all frames. 

Note: Delay time may not be accurate during an animation preview in 

ImageReady. For an accurate preview of delay time, preview 

animations in a browser. 

Getting Additional Help 

The Help Desk provides consulting and Q&A help in a variety of ways: 

785/864-0200 

question@ku.edu 

www.ku.edu/~helpdesk 
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