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Abstract: Learn to customize layouts. Create simple report layouts such as 
mailing labels, as well as complex layouts with summary data. 
Learn about relational databases: how to define relationships and 
lookups, and display data from related files. Get started with 
scripts, formulas, and functions. Publish your database on the 
World Wide Web. 
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Introduction 
This workshop expands on the coverage of layouts in FileMaker Pro: Introduction to 
include summaries, printing of mailing labels and envelopes, and removing blank space 
from printed data. It demonstrates an important aspect of good database design, the 
relationship, and describes the methods for setting up different types of relationships 
between files. Participants also learn how to display related information from two or 
more files. Scripts are introduced, which can be used to automate many tasks, including 
switching to another layout; switching to another mode; and finding, sorting, and printing 
records. Formulas and functions are also introduced. Publishing databases on the World 
Wide Web using FileMaker Pro Web Companion is demonstrated. 

Objectives 
The goal of this workshop is to introduce participants to scripts and file relationships in 
FileMaker Pro. After today’s workshop, participants will be able to: 

• Print mailing labels and envelopes 

• Create layouts with merge fields and sliding objects to close up blank space 

• Create relationships between two or more files. 

• Create a script to select records from a file. 

• Publish a database on the Web. 

Prerequisites 
It is assumed that the participants in this workshop have taken FileMaker Pro: 
Introduction or have equivalent skills. 

Related Training Available from ACS 
All workshops offered by Academic Computing Services (ACS), a division of 
Information Services, are free to KU students, staff, faculty, and approved affiliates. The 
general public is also welcome to most workshops, but some ACS workshops require a 
registration fee for them. 

To learn more about or register for workshops, receive automatic announcements of 
upcoming workshops, and track workshops you’ve registered for and have attended, visit 
the ACS Web site at www.ku.edu/acs/train. You can also check our online schedule at 
www.ku.edu/acs/schedule for a list of class offerings and their availability. For further 
workshop related questions, please email training@ku.edu. 

Modes 
FileMaker Pro: Introduction introduced you to three of FileMaker Pro’s four modes: 
Browse, Find, and Layout. The fourth mode, Preview, is used to see how data in forms or 
reports will look before you print. Preview mode is especially useful for layouts with 
multiple columns (like mailing labels—see page 4) and grouped reports with summaries 
(see page 4). 
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Layouts 

Summaries 
Summary fields can be used to calculate values across multiple records, like subtotals, 
averages, and grand totals. You must define a summary field for each field you want 
summarized. You then place these summary fields in a summary layout part. Grand 
summary and subsummary layout parts contain summary fields, and determine their 
behavior. Grand summaries display summary information about all records being 
browsed. Subsummaries display information for a subset of records. The records are 
grouped (sorted) by values in the break field. Whenever the value of the break field 
changes, the report “breaks” and FileMaker Pro inserts the subsummary part. 

The New Layout/Report assistant can be used to quickly create a report with summarized 
data, by selecting its Columnar list/report type. 

To add a summary part to a blank or existing layout, drag the Part tool from the tool 
panel to the position you want on the layout, then select the summary part type in the 
Part Definition dialog. For subsummaries, also select the break field. 

Notes: • The value in a summary field can change depending on where you 
place the field on a layout (whether in a grand summary or 
subsummary part), how many records are in the found set, whether  
the records are sorted (and how), and which mode you are using. 

• FileMaker Pro displays subsummary parts and calculates 
subsummary data correctly only in Preview mode or in a printed 
report. 

• When you view records as a list in Browse mode, subsummary 
parts aren’t displayed. 

• You can have only one leading and one trailing subsummary part 
based on the same field. 

Using the built-in layout types 
In addition to offering basic layout types like Standard form and Columnar list/report, 
FileMaker Pro’s New Layout/Report assistant can semi-automatically guide you through 
the completion of everyday tasks like printing mailing labels or envelopes. 

Labels 
FileMaker Pro includes presets for a large number of standard label types. If the label 
type you want isn’t available, you can specify custom label dimensions. 

1. Choose Layout Mode from the View menu 
or 
choose Layout from the Mode pop-up menu at the bottom of the document window. 

2. Choose New Layout/Report from the Layouts menu 
or 
click the New Layout/Report button on the Standard Toolbar. 
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The New Layout/Report button 

3. In the New Layout/Report window, type a unique name in the Layout Name text 
box, or keep the default that FileMaker Pro provides. 

4. Select Labels from the Select a layout type list. 

 
The New Layout/Report window with Labels selected. 

5. Click Next. 

6. Select the label size from the Use label measurements for pop-up menu 
or 
Click the Use custom measurements radio button and define the label 
measurements. 
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The New Layout/Report window with Avery 5160 selected. 

7. Click Next. 

8. Select the fields that are to appear on the label layout by clicking their names in the 
Available fields list and then clicking the Add Field button, or by simply double-
clicking their names. When you add a field, it appears in the Label contents box at 
the bottom of the window just as it will on the label. You can also type directly into 
this box to insert text, spaces, punctuation, or line returns. Format the fields as you 
like, then click Next. 
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The New Layout/Report window with field contents specified. 

9. Select how you’d initially like to view the new layout. 

10. Click Finish. 

Envelopes 
The Envelope layout is for printing to standard “Number 10” business envelopes. 

1. Follow steps 1–3 under Labels, above. 

2. Select Envelope from the Select a layout type list and click Next. 

3. Specify the envelope contents as described under step 8 above. 

4. Follow steps 9–10 above. 

Merge Fields 
The Label and Envelope layout types use merge fields—placeholder text in Layout mode 
that is replaced by the field’s value when you browse, preview, or print the layout. Merge 
fields shrink or expand to fit the amount of text in the field for each record. (This 
behavior includes collapsing an entire line, such as an empty Address Line 2 field, if the 
field is by itself on a line and the field contains no data.) 

You can use merge fields on any layout. To place a merge field on a layout: 
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1. In Layout mode, select the Pointer tool or the Text tool in the tool panel. (Use the text 
tool to insert the merge field into a line of text.) 

 
The Pointer tool (left) and Text tool (right). 

2. Click where you want FileMaker Pro to place the merge field. 

3. Choose Merge Field from the Insert menu. 

4. In the Specify Field dialog, select the field to insert. 

5. Click OK. 

Insert punctuation and spaced between merge fields as needed on the layout, but be 
careful not to type extra characters inside the << and >> symbols. 

You can also insert a merge field by typing the field name, surrounded by the << and >> 
symbols, directly on the layout. Note that the merge field characters are not single 
characters (« and »), but double opening (<<) and closing (>>) angle brackets. 

To specify text attributes to be used when you browse, preview, or print the field data in a 
merge field, select the merge field name and the << and >> symbols in Layout mode, 
then select formatting options. 

Sliding objects 
Often, the amount of information in the fields in your database varies. When you print, 
FileMaker Pro can shrink field boundaries and shift objects to the left or up on your 
layout to close up the blank space that results when the information in a field doesn’t fill 
the field boundary. Merge fields are, effectively, one way to accomplish this. You can 
also do so by sliding objects. While merge fields eliminate unnecessary space only 
between a field and layout text or adjacent fields in a continuous block of text, sliding can 
be applied to fields, portals (see page 15), other objects, and even layout parts. 

To set sliding options: 

1. In Layout mode, select the object(s) you want to slide. Also select the left-most (or 
top-most) field that you want other objects to slide into so it can shrink. 

To allow fields to shrink when you specify sliding left, align their top edges and 
choose Format menu > Align Text > Left. To allow fields to shrink when you 
specify sliding up, choose Format menu > Align Text > Top. 

2. Select the object(s) to slide, then choose Sliding/Printing from the Format menu. 

3. In the Set Sliding/Printing dialog, select the sliding options you want. 
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Select this 
option 

To 

Sliding left Reduce the width of the selected fields to the minimum needed 
for their data, and then slide all selected objects left based on the 
amount of space the fields shrink. 

Sliding up based 
on: then click All 

above 

Reduce the height of the selected fields to the minimum needed 
for their data, and then slide all selected objects up based on the 
field above that shrinks the least. 

This option maintains consistent vertical spacing among columns 
and repeating fields. 

Sliding up based 
on: then click Only 

directly above 

Reduce the height of the selected fields to the minimum needed 
for their data, and then slide all selected objects up based on the 
amount of space the fields directly above shrink. 

This option allows the spacing in a column to adjust 
independently of other columns and repeating fields. 

Also reduce the 
size of the 

enclosing part 

Close up the space in the layout part that contains the selected 
fields. To slide the part up relative to all objects, set this option for 
all the objects that are sliding up. To slide the part up relative to a 
single object, set this option for that object only. 

4. Click OK. 

5. Choose Preview Mode from the View menu to see the effects of the sliding options. 

Review: databases and database design 

Databases 
A database is an organized collection of data. A relational database is a database in 
which the organization of the data incorporates the way data items are related to one 
another. In particular, data in a relational database is stored in one or more files (also 
called a table or relation). A file is conceptually a two-dimensional array of fields (also 
called columns or attributes) and records (also called rows or tuples). Relational 
databases are very versatile. 

A database consisting of multiple files can offer some advantages over a single-file 
database. Consider, for example, a database of student information including ID numbers, 
names, addresses, classes, and grades. A single-file database for this example might have 
these nine fields: 

Academic Computing Services - 9 - © 2003 The University of Kansas. 
A Division of Information Services 



ACS Computer Training 
FileMaker Pro Intermediate 

students 
ID MMMMMM 
last MMMMMM 
first MMMMMM 
street MMMMMM 
city MMMMMM 
state MMMMMM 
zip MMMMMM 
class MMMMMM 
grade MMMMMM 

 

Notice that for every class in which a student receives a grade, the ID, last, first, street, 
city, state, and zip for that student must be repeated in the file! 

If the database has multiple, related files, however, we can have one file for name and 
address information, and another for grade information: 

students 
ID MMMMMM 
last MMMMMM 
first MMMMMM 
street MMMMMM 
city MMMMMM 
state MMMMMM 
zip MMMMMM 

 

grades 
ID MMMMMM 
class MMMMMM 
grade MMMMMM 

 

Because the common ID field relates the two, we can use this to send a student’s grade 
report using the name (last, first) and address (street, city, state, zip) from the first file 
and the class and grade data from the second. Notice that this eliminates a considerable 
amount of data duplication and opportunity for error. Notice also that the data can be 
used however we wish, without regard for the database structure; in our example, 
information is combined from both files, and not all fields are utilized (only the name and 
address would appear on the envelope, for instance). Modification of the database 
structure is similarly flexible in the multiple-file relational model. 

Relational databases are the predominate form of database in use today, and are the type 
on which this class focuses. 

Database design 
Of course, some ways of organizing data are better than others, and you face a number of 
choices when creating a database. What data is to be included? What will the fields be? 
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How will they be divided into multiple files? Which fields will the individual files share 
with each other? These are important considerations, and, in general, it is vital that you 
plan your database design carefully. It should be capable of accommodating all the data 
you can foresee needing to store, but should not waste storage space on data you don’t 
need. It should also be immune to errors or inconsistencies arising from changes made to 
data items, now or in the future. 

Besides thoughtful consideration of the needs your database must meet, there are formal 
means of making (some) database design decisions, those of database normalization. A 
database that is normalized has certain structural characteristics that make it more 
efficient and less susceptible to data integrity problems than one that is not. There are 
multiple levels of normalization, the first three of which are sufficient for most common 
situations. 

For a database to be in first normal form, there must be no repeating fields, each cell of 
the file must have only a single value, and each file record must be unique. Records are 
guaranteed to be unique through the use of match fields. A match field (also called a 
primary key) is a field or group of fields whose values uniquely identify a record in a file.  

For example, consider a database of retail clothing items with the following file: 

item colors price tax 

T-shirt red, blue 12.00 0.60

polo red, yellow 12.00 0.60

T-shirt red, blue 12.00 0.60

sweatshirt blue, black 25.00 1.25

It is not in first normal form, both because the cells in the colors field have multiple 
items, and because there are duplicate records, i.e., there is no match field. Eliminating 
the duplicate record and splitting the colors into their own cells brings it to first normal 
form: 

item color price tax 

T-shirt red 12.00 0.60

T-shirt blue 12.00 0.60

polo red 12.00 0.60

polo yellow 12.00 0.60

sweatshirt blue 25.00 1.25

sweatshirt black 25.00 1.25

Here, item and color together comprise the match field. Notice that it is almost trivial to 
obtain first normal form. 
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Second normal form requires that, if the match field is a combination of multiple fields, 
all non-key fields must depend on all components of the key. Put another way, no field 
can be dependent upon just one part of the match field. 

In our example, price and tax depend on item, but not color, so the file is not in second 
normal form. Splitting the file into two brings about second normal form: 

item color  item price tax 

T-shirt red  T-shirt 12.00 0.60

T-shirt blue  polo 12.00 0.60

polo red  sweatshirt 25.00 1.25

polo yellow     

sweatshirt blue     

sweatshirt black     

Notice that item and color still make up the match field for the left file, and item is the 
match field for the right file. Notice also that a file in first normal form whose match field 
is a single field is automatically in second normal form as well. 

Third normal form is attained when no non-key field depends upon a field other than the 
match field. 

In our example, price depends on item, the match field, but tax depends on price, not 
item. This is called a transitive dependency, and must be eliminated to bring the database 
into third normal form. Splitting the file once more does the trick: 

item color  item price price tax 

T-shirt red  T-shirt 12.00  12.00 0.60

T-shirt blue  polo 12.00  25.00 1.25

polo red  sweatshirt 25.00    

polo yellow       

sweatshirt blue       

sweatshirt black       

(Incidentally, FileMaker Pro features calculation fields, which can be used to compute 
values like tax automatically.) 
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Creating relationships 
Relationships are connections between files in a database that allow many files with 
similar fields to share data. This not only creates consistency in records, it also helps keep 
the size of the database manageable by reducing the duplication of data. 

In use, relationships allow you to display fields from multiple files in a layout. The basic 
idea is that a link can exist between two files that have matching fields, allowing you to 
reference data in the related file from within the master file through that link. For 
example, a file of courses offered by a department on campus could be linked to a file of 
the professors in that department. The “course” file might have information about the 
course number, meeting times, credits, and a single field reference to the instructor. The 
“professors” file would have information about their office addresses, office hours, phone 
numbers, as well as the courses they are teaching. Through a common field identifying 
the professor’s record in the courses file, the two files can be linked. 

Types of file relationships 
There are three kinds of linking relationships that can be established between files 

One-to-one 
A one-to-one relationship exists between two files when each record in the master file has 
exactly one matching record in the related file. For example, for each record in a file of 
all the currently enrolled students at the university, there would be one and only one 
record in a file containing all the past and present students at the university. 

One-to-many 
A one-to-many relationship exists between two files when one record in the master file 
matches many records in the related file, but one record in the related file matches only 
one record in the master file. For example, in a file of courses, each course would have 
only one instructor, but in a file of instructors, each instructor may teach several courses. 

Many-to-many 
A many-to-many relationship exists between two files when one record in the master file 
matches many records in the related file, and one record in the related file matches many 
records in the master file. For example, in a file of courses, each course has many 
students, and in a file of students, each student can take several courses. 

Creating a many-to-many relationship requires creation of a separate join file. See the 
explanation below. 

To create a relationship 
To create relationships between two or more files: 

1. In the master file, choose Define Relationships from the File menu. 

2. In the Define Relationships dialog, click New. 

3. In the dialog that appears, double-click the name of the related file (the file to define 
a relationship to). 
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The Edit Relationship dialog. 

4. In the Edit Relationship dialog, type a unique name in the Relationship Name text 
box, or keep the default that FileMaker Pro provides. 

Don’t include colons (:) in the name. FileMaker Pro ignores any spaces at the end of 
names. 

5. Select a match field for the master (current) file in the left list, and a correspondingly 
valued match field for the related file in the right list. Click each field name once to 
select it. The match field in the related file containing the same values as a match 
field in the master file is sometimes called a foreign key in the related file. 

6. To have related records sorted, select Sort related records. Then, in the Specify 
Sort dialog, specify sort instructions for the related fields. 

Selecting this option does not affect the sort order in the related file. 

7. Select additional options if desired. 

To delete matching records in the related file whenever you delete a record in the 
master file, select When deleting a record in this file, also delete related records. 

To add records to the related file by entering data into related fields in the master file, 
select Allow creation of related records. 

8. When you’re finished, click OK, then click Done. 

Once you’ve created a relationship, you can add fields to display data from the related 
file on a layout of the master file, and work with the data in the related fields when you 
work with records in the master file. 
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Portals 
A portal is a layout object that can be used, for one-to-many relationships, to display data 
from more than one related record for each record in the master file. Portals display data 
from related fields in rows, one record in each row. 

To create a portal: 

1. In Layout mode, select the Portal tool in the tool panel. 

 
The Portal tool. 

2. Position the crosshair pointer on the layout where you want the portal to begin, then 
drag the pointer diagonally until the portal is the size you want. 

3. In the Portal Setup dialog, choose the relationship to use from the Show records 
from pop-up menu. Alternatively, you can choose Define Relationships to create a 
new relationship. 

4. Select options for the portal. 

5. Click OK. 

6. Place related fields in the portal. 

Creating a many-to-many relationship 
Although FileMaker Pro allows you to explicitly create one-to-one and one-to-many 
relationships, you must create an intermediate file, called a join file, between two files 
where you want to create a many-to-many relationship. The join file needs just two 
fields: the two match fields for the two files you want to link. 

For more information about creating many-to-many relationships between database files, 
choose Contents and Index from the Help menu, click the Index tab, and type many-
to-many correspondence. 

Lookups 
In a relational database, data from a related file can be displayed, edited, and used in the 
master file while always remaining part of the related file only, so that data displayed in 
the master file changes whenever data in the related file changes. In contrast, a lookup 
copies data from a related file into a field in the master file. After the data is copied, it 
becomes part of the master file (and remains in the file it was copied from). Data copied 
to the master file doesn’t automatically change when the data in the other file changes. 
Lookups, then, are used to copy data from a related file and keep it as copied, even when 
the data in the related file changes. For example, use a lookup to copy the price of an item 
at the time of purchase into an invoice file. Even if the price in the related file changes, 
the price in the invoice file stays the same. 

To define a lookup: 

1. Define a relationship for the lookup as directed in To create a relationship on page 
13. 
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Note: Selection of the additional options described in step 7 is not applicable 
to lookup relationships. 

2. In the master file, choose Define Fields from the File menu. 

3. In the Define Fields dialog, double-click the lookup destination field (the field in the 
master file to copy data to), or create a new field, then double-click it. 

4. Click the Auto-Enter tab, then select Looked-up value. 

5. In the Lookup dialog, choose the relationship to use from the relationship pop-up 
menu. 

6. In the list of field names, select the lookup source field (the field in the related file to 
copy data from). 

7. Select options for the lookup. 

8. Click OK. 

9. Click OK. 

10. Click Done. 

Scripts 
FileMaker Pro includes the ScriptMaker feature, which you can use to automate many 
tasks, such as switching to another layout or mode; finding, sorting, and printing records; 
importing data from the same source; or dialing phone numbers. One simple script 
example is demonstrated here. 

Finding records 
In FileMaker Pro: Introduction, you learned how to specify criteria for finding specific 
records. Though it’s normally necessary to specify the criteria each time you perform a 
find, you can use a script to allow you to perform the same find whenever you like, 
without having to specify its criteria. 

1. In Find mode, specify the criteria you want, as explained in FileMaker Pro: 
Introduction. 

2. Choose ScriptMaker™ from the Scripts menu. 

3. Type a name in the Script Name text box. 

4. Click the Create button. 

5. FileMaker Pro includes default steps when you create a script. You can change or 
delete these steps. Since none of the default steps are necessary for this script, click 
the Clear All button. 

6. Scroll down the list on the left until the Sort/Find/Print options are visible 
or 
choose Sort/Find/Print from the View pop-up menu. 

7. Double-click Perform Find in the list. 
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The Script Definition dialog. 

8. Click OK. 

9. Click Done. 

To use your script at any time, choose its name from the Scripts menu. Doing so will 
perform a find with the set of criteria that was specified when you defined the script. 

Using formulas and functions 
In FileMaker Pro: Introduction, Calculation was listed among the possible field types as 
storing the result of a calculation formula. A formula is a specific operation on one or 
more values in the database. Formulas can include any combination of constants, field 
references, operators, and functions (see below). These elements are arranged in a 
particular order, or syntax, to produce expressions giving the result you want. 

You create formulas in the Specify Calculation dialog. 

You can use calculations in several areas of FileMaker Pro, namely: 

• when defining calculation fields 

• in certain script steps 

• to auto-enter calculated values 

• for data validation 

• when using Replace with calculated results 
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The Specify Calculation dialog. 

For more information about formulas, choose Contents and Index from the Help menu, 
click the Index tab, and type formulas. 

A function is a predefined, named formula that performs a specific calculation and returns 
a single, specific value. FileMaker Pro includes many functions in the following 
categories: 

• Text functions 

• Number functions 

• Date functions 

• Time functions 

• Aggregate functions 

• Summary functions 

• Repeating functions 

• Financial functions 
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• Trigonometric functions 

• Logical functions 

• Status functions 

• Design functions 

• External functions 

For more information about functions, choose Contents and Index from the Help menu, 
click the Index tab, and type functions. 

Publishing databases on the Web 
FileMaker Pro provides a simple way to publish your databases on the World Wide Web 
(or an intranet), called Instant Web Publishing. This uses the provided Web Companion 
plug-in. 

Overview 
To publish FileMaker Pro databases on the Web you must: 

1. Enable the Web Companion plug-in 

2. Enable Instant Web Publishing 

3. Configure Web Companion 

For each database you publish, you must: 

1. Enable Web Companion Sharing 

2. Choose a web style and set up browser views 

Enabling Web Companion 
1. Choose Edit menu > Preferences > Application. 

2. Click the Plug-Ins tab. 

3. Check Web Companion. 

4. Click Web Companion to select it. 

5. Click the Configure button. 

6. Check Enable Instant Web Publishing. 

7. Specify a port number in the TCP/IP Port Number text box. The port number 
specifies where web browsers can find your FileMaker Pro databases. 80 is the 
default for web servers; use it if no other web server applications are running on your 
computer. If port number 80 is already in use, consider changing TCP/IP Port 
Number to 591, which FileMaker, Inc. has registered with the Internet Assigned 
Numbers Authority (IANA) for use with FileMaker Pro Web Companion. 

8. Click OK. 

9. Click OK. 
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Note: If you use a port number other than 80, web users cannot access your 
database unless they append a colon, and the new port number, to your 
IP address (or host and domain name). For example, users would type 
12.34.56.78:591 or http://account.yourcompany.com:591/. 

Enabling Web Companion sharing 
For each database you want to publish on the Web: 

1. Choose Sharing from the File menu. 

2. Check Web Companion. 

3. Click the Set Up Views button. 

4. On the Web Style tab, choose a style from the Styles pop-up menu. 

5. If desired, you can select the layouts to be used and the fields to be included on the 
Table View, Form View, and Search tabs. In practice, you may want to define 
layouts specifically for these Web views before publishing your database on the Web. 

6. If you want to specify sorting options for records displayed in the browser, click the 
Sort tab and select the desired options. 

7. Click Done. 

8. Click OK. 

Testing your published database 
To test your published database, open a Web browser, and enter your computer’s IP 
address (or hostname). Include the colon and port number if necessary. Your shared 
database should be listed on the FileMaker Pro Instant Web Portal page that appears. 

Notes: • FileMaker Pro must be running, and the database(s) to be shared 
must be opened in order for Web access to be enabled. 

• Your computer must be connected to the Internet (or intranet) to 
serve your database(s). 

• Some versions of FileMaker Pro impose limitations on the number 
of users who can access your online database(s) at any one time. 
To find out the maximum number of users that can access a 
published database, follow steps 1–5 under Enabling Web 
Companion above, and examine the value for IP Guest Limit. 

For more information about configuration options, customization, security, etc., choose 
Contents and Index from the Help menu, click the Index tab, and type About 
publishing databases on the Web. 
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For More Information 
Here are some additional sources of information about FileMaker Pro: 

Online 
The FileMaker Pro Web site is at http://www.filemaker.com/. It includes a support page 
at http://www.filemaker.com/support/index.html and a selection of Web resources at 
http://www.filemaker.com/webresources/index.html. 

Getting Additional Help 
ACS provides consulting and Q&A help in a variety of ways: 

785/864-0200 
question@ku.edu 
www.ku.edu/acs/help 

 

Last Update: 05/16/2002 
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