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Abstract: This workshop focuses on the functions and data analysis tools 
of Microsoft Excel. Topics included are the functions such as 
AVERAGE and SUM, and data analysis tools such as pivot 
tables and conditional summations. 
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Introduction 
Microsoft Excel consists of three basic parts: its spreadsheet, chart, and list management 
utilities. Using a single set of data, these separate utilities can work together or 
individually. This workshop concentrates on inserting and using functions and other data 
analysis tools. 

Objectives 
The goal of this workshop is to introduce participants to the more complex features of 
Excel. After today’s workshop participants will be able to: 

• define terms related to using functions 

• create and edit a function 

• identify add-in functions 

• perform data analysis using Data Analysis Tools 

• create a formula with the Conditional Sum wizard 

• learn to troubleshoot a formula 

Prerequisites 
It is assumed that the participants in this workshop have either taken the Excel: Data 
Management workshop or have equivalent skills. 

Related Training Available from Instructional Services 
All workshops offered by Instructional Services are free to KU students, staff, faculty, 
and approved affiliates. 

To learn more about or register for workshops, receive automatic announcements of 
upcoming workshops, and track workshops you’ve registered for and have attended, visit 
www.lib.ku.edu/instruction/workshops. For further workshop related questions, please 
email training@ku.edu. 
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Definitions 

Term Definition 

Formula A formula is an equation that performs a calculation on data in your 
worksheet. Formulas calculate simple values such as addition or 
multiplication, or more complex values using Excel’s built-in functions. In 
Excel, all formulas begin with an equal sign (=) and are followed by any 
valid combination of data, references, operators, or built-in functions. 

Formula 
syntax 

Formula syntax is the required structure or order of formula elements. All 
formulas begin with an equal sign (=) followed by operands (the data to be 
calculated) and operators. Operands can be values that don’t change 
(constants), range references, labels, names, or built-in functions. 

Formula 
bar 

The formula bar is the area located at the top of the worksheet window 
that is used to enter or edit values or formulas in cells. The formula bar 
displays the constant value or formula in the active cell. To display or hide 
the formula bar, click Formula Bar on the View menu. 

Order of 
precedence 

Formulas are calculated left to right, using order of precedence rules, 
unless the use of parentheses changes the order of calculation. 

Example: = 10+10*4 or = (10+10)*4 

Excel performs operations in the order shown in the following table. If a 
formula contains operators with the same order of precedence, Excel 
evaluates the operators from left to right. For example, if you enter the 
formula = 7 + 7 - 5, the calculation is performed left to right since both + 
and - have the same precedence. If you enter the formula = 7 + 7 * 5, 
Excel performs the multiplication first since * has a higher precedence 
than +.  

To change the order of evaluation, enclose the part of the formula to be 
calculated first in parentheses. 

Operator Description 

: (colon), (comma) (single space) Reference operators 

- Negation (as in -1) 

% Percent 

^ Exponentiation 

* and / Multiplication and division 

+ and - Addition and subtraction 

& String Concatenation 

=, <, >, <=, >=, <> Comparison 
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Function A function is a predefined formula that performs calculations by using 
specific values in a particular order. The values used in the function are 
called arguments, and these arguments must appear in a specific order. 
For example, the AVERAGE function calculates the average of its 
arguments. 

Arguments Arguments can be numbers, text, logical values such as TRUE or FALSE, 
arrays, error values such as #N/A, dates and times, or cell references. The 
argument you designate must produce a valid value (i.e., if the function is 
expecting a number, text is not a valid value for that argument). 
Arguments can also be formulas or other functions. 

Function 
syntax 

The syntax of a function begins with the function name, followed by an 
opening parenthesis, the arguments for the function separated by 
commas, and a closing parenthesis. If the function starts a formula, an 
equal sign (=) should be placed before the function name. 

Example: SUM(D2:F8) 

In the above example, the function name is SUM and the argument for the 
function is the range D2:F8. 

Function 
Arguments 

window 

The Function Arguments window helps you create or edit a function and 
also provides information about functions and their arguments. 

Add-ins Add-ins are programs that provide optional commands and features. To 
make an add-in available, you must first install the add-in and then load it. 
Once an add-in is loaded, it is available within Excel. Add-ins might place 
additional commands on Excel menus. 

Add-ins use a lot of memory, so unload add-ins you do not use often. 
Unloading an add-in only removes its features and commands from Excel, 
it does not delete the add-in. An add-in that has been unloaded can be 
reloaded since it remains on your computer. 

A list of all add-ins automatically installed with Excel is available in the 
online help. On the Help menu, click Microsoft Excel Help and enter 
Add-in programs included with Excel. 

You can also use Visual Basic programs as custom add-ins. 
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Inserting Functions 
The Insert Function dialog box is designed to help in the construction and use of the 
various built-in functions and their arguments. 

To insert a function: 

1. Select the cell in which you want the results of the function to display.  

2. Click the Insert Function button on the Formula Bar ( ) or select Insert > 
Function in the menu. The Insert Function dialog box appears. 

3. Choose the function you wish to use by either 

• Typing a description of the function and clicking Go, or 

• Selecting a function category from the drop-down menu.  

 

The Insert Function dialog box 

4. Double-click the name of the function, or click the function and click OK. 

5. The Function Arguments dialog box appears. Some things to note about it include: 

• When you click in the blank field beside each argument name, a description of 
that argument appears at the bottom of the window. A description of the function 
itself also appears.  

• Each argument can be a constant value (i.e., a number), a reference to another 
cell or range, or the result of another formula. 

• Some functions have a predefined number of arguments, while others can have a 
variable number of arguments. For those functions that can take a variable 
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number of arguments, Excel automatically provides you with a blank field for an 
additional argument after each argument you add.  

• The value of each individual argument is calculated and displayed to the right of 
the argument’s input field, and the overall result of the function is displayed at 
the bottom next to Formula result =.  

 

The Function Arguments window for the AVERAGE function. Note that the three 
arguments entered take the form of a number, a range reference, and a formula result, 

respectively. The value of each argument is displayed to the right of its input field.  

6. Fill in the arguments. To select ranges on your worksheet, click  beside the 
appropriate field. Excel collapses the Function Arguments window so that you can 
click and drag to select the correct range on your worksheet. To return to the 

expanded Function Arguments window, click  or press Return.  

7. Click OK. The Function Arguments window closes and returns you to your 
worksheet with the results in the active cell. The formula appears in the Formula 
Bar. 

Sample Functions 

CONCATENATE 
The CONCATENATE function joins several text strings into one text string. The “&” 
operator can be used instead of CONCATENATE to join text items. 

Syntax 
CONCATENATE(text1,text2,...) 
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 Arguments 
Text1, text2, … are 1 to 30 text items that are joined into a single item. The text 
items can be text strings, numbers, or single-cell references. 

Notes 
CONCATENATE("Instructional Services ","at ","KU Libraries") is 
equivalent to "Instructional Services at KU Libraries". (Note the extra space after 
“Instructional Services” and “at”. It is important to note that CONCATENATE 
does not insert spaces for you.) If cell A2 contains "Instructional Services " and 
B2 contains "at " then CONCATENATE(A2,B2,"KU Libraries") is equivalent 
to " Instructional Services at KU Libraries". 

COUNT 
Counts the number of its arguments that contain numbers. 

Syntax 
COUNT(value1,value2,...) 

 Arguments 
Value1, value2, … are 1 to 30 arguments that can contain or refer to a variety of 
different types of data, but only numbers are counted. (Excel treats dates and 
times as numbers, so they will be counted.) 

COUNTA 
Counts the number of cells that are not empty. Use COUNTA to count the number of 
cells that contain data in a range or array. 

Syntax 
COUNTA(value1,value2,...) 

 Arguments 
Value1, value2, … are 1 to 30 arguments representing the values you want to 
count. In this case, a value is any type of information, including empty text ("") 
but not including empty cells. 

COUNTBLANK 
Counts empty cells in a specified range of cells. Cells with formulas that return "" (empty 
text) are also counted (thus cells with empty text are counted by both COUNTA and 
COUNTBLANK). Cells that evaluate to zero are not counted. 

Syntax 
COUNTBLANK(range) 
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 Arguments 
Range is the range of cells in which you want to identify blank cells. 

COUNTIF 
Counts the number of cells within a range that meet the given criteria 

Syntax 
COUNTIF(range, criteria) 

 Arguments 
• Range is the range of cells in which you want to count cells. 

• Criteria is a string that must be satisfied for the cell to be counted. Some 
examples: 

o 123456 or "123456" counts a cell only if it contains exactly 123456.  

o ">123456" counts a cell only if its contents are greater than 123456. 

o "enrolled" counts a cell only if it contains exactly the text enrolled.  

VLOOKUP 
In general, lookup functions are used to look up data in a list and return a corresponding 
value. VLOOKUP (vertical lookup) is one of several lookup functions, but since data is 
generally organized in columns, VLOOKUP is used frequently. 

Syntax 
VLOOKUP(lookup_value,table_array,col_index_num,range_lookup) 

 Arguments 
• Lookup_value is the value to be found in the first column of the table array. 

The lookup_value can be a value, a reference, or a text string. 

• Table_array is the table of information in which data is looked up. If you 
create a range name like List or Sales_Table, it is easy to copy the function 
without losing your reference to the table range. Otherwise you will need to 
use absolute addressing in specifying the table. The values in the first column 
of table_array can be text, numbers, or logical values. 

• Col_index_num is the column number in the table_array from which the 
matching value must be returned. For example, a col_index_num of 2 returns 
the value in the second column in table_array. If col_index_num is less than 
1, VLOOKUP returns the #VALUE! error value; if col_index_num is greater 
than the number of columns in table_array, VLOOKUP returns the #REF! 
error value. 

• Range_lookup is a logical value that specifies whether you want VLOOKUP 
to find an exact match or an approximate match. If the range_lookup 
argument is omitted (and thus treated as TRUE), an approximate match is 
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returned. If an exact match is not found, the next largest value that is less 
than lookup_value is returned. If range_lookup is FALSE, VLOOKUP will 
find an exact match and if an exact match is not found, the error value #N/A 
is returned. 

Notes 
If range_lookup is TRUE, the values in the first column of table_array must be 
placed in ascending order, otherwise VLOOKUP may not give the correct value. 
If range_lookup is FALSE, table_array does not need to be sorted. 

Example  

 

Using the VLOOKUP function 

Using the above image as an example, the VLOOKUP formula is placed in the 
Bonus column in the table on the right.  

The Sales column is the lookup_value and, from the table on the left, the Sales 
Level column and the Bonus Rate column comprise the table_array, since you 
want to determine what rate should be paid for corresponding sales. 

The col_index_num is 2 since the rate that you want to report is in the second 
column of the table_array. The range_lookup is TRUE because we don’t need to 
match the sales exactly; in such a case, you can omit the range_lookup or type 
TRUE. Note that since the Sales value does not match the Sales Level exactly, 
the table on the left must be sorted by the Sales Level column in ascending order.  

Add-In Commands and Functions 
An add-in is a set of commands or functions that, once loaded, appears to be a part of the 
Excel program. Add-in commands or functions may be user-created macros or those 
included with Excel. Some Excel add-ins are automatically loaded when Excel is 
installed; the user loads others. Not all add-ins are automatically loaded because add-ins 
use a lot of memory. 

Loading an Add-In 
Once an add-in is loaded, it is always available until you unload it. To load an add-in, 

1. On the Tools menu, click Add-Ins. The Add-Ins dialog box appears. 

2. In the Add-Ins available list, click the checkbox next to the add-in you want to load. 
If the add-in you want to use is not listed, click Browse and then locate the add-in. If 
the add-in is not installed on your computer, you must install it. 
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3. Click OK. 

Unloading an Add-In 
Unloading add-ins that you don’t use can save memory since all loaded add-ins are 
always loaded into memory when Excel is opened. 

1. On the Tools menu, click Add-Ins. 

2. In the Add-Ins available list, clear the checkbox next to the add-in you want to 
unload. 

3. Click OK. 

When you unload an add-in, it is not deleted from your computer. 

Data Analysis Tools 

Histogram 
The Analysis ToolPak is one of several add-ins available with Excel. Its data analysis 
tools are used in the collection, organization, and interpretation of numeric data. A 
histogram is one tool in the Analysis ToolPak that shows how frequently values occur in 
each numeric interval of a specified range. 

Setting Up the Data 
A histogram counts how many of the values in a range (input range) fall within specified 
numeric intervals (bins). For example, in a group of people, you could determine the 
distribution of ages within age categories. 

You need to set up your worksheet before running the Histogram data analysis tool. You 
need to specify the following: 

• The input range: the range of values to analyze. 

• The bin range: the range of cells that contain a set of boundary values. The bin range 
is optional. If you omit the bin range, the Histogram tool creates a set of evenly 
distributed bins between the data's minimum and maximum values. However, 
because these bin intervals may have little relation to your data, or the type of 
analysis you are looking for, it is recommended that you create your own bins. 

• The output range: an area to display the histogram. 

Input Range 
In the example below, the Age column is the input range since this is the column of data 
to analyze. 
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Bin Range 
In the example above, the bin range contains the age intervals. When setting up a 
histogram, make sure the intervals for the bin range are specified in ascending order. 

Output Location  
The results of the distribution can be placed in an area on the current worksheet, on 
another worksheet within the same workbook, or in another workbook. 

Creating the Histogram 
Before accessing the Histogram tool, make sure your worksheet is set up properly. See 
Setting Up the Data, above. 

To create a histogram: 

1. Choose Data Analysis from the Tools menu  

2. Select Histogram from the Analysis Tools list in the Data Analysis dialog box. 

3. Click OK to display the Histogram dialog box. 
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The Histogram dialog box 

4. Enter the range of cells to analyze in the Input Range box. 

5. Enter the bin range in the Bin Range box. If you omit the bin range, Excel creates a 
set of evenly distributed bins between the data’s minimum and maximum values. 

6. Specify the output location. See Output Options, below.  

Output Options 

Output Range 
Enter the reference for the upper-left cell of the output table. The size of the output area is 
automatically determined and Excel displays a message if the output table might 
overwrite existing data. 

New Worksheet Ply 
Click to insert a new worksheet in the current workbook and paste the results starting at 
cell A1 of the new worksheet. You can name the worksheet by typing a name in the input 
area after selecting New Worksheet Ply. 

New Workbook 
Click to create a new workbook and paste the results on a new worksheet in the new 
workbook. 

Other Histogram Options 

Labels 
Select Labels if the first row or column of your input range contains labels. Clear this 
checkbox if your input range has no labels; Excel generates appropriate data labels for the 
output table. 
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Pareto 
If the Pareto box is checked, the output data table includes the results displayed in 
descending order of frequency. 

Cumulative Percentage 
If the Cumulative Percentage box is checked, Excel generates an output table column 
for cumulative percentages. Leave unchecked to omit the cumulative percentages. 

Chart Output 
Select Chart Output to generate an embedded histogram chart with the output table. 

Conditional Sum 
Use the Conditional Sum Wizard, another add-in, to summarize values in a list based on 
specific conditions. The Conditional Sum Wizard can help you determine the number of 
records in a table that meet a certain criteria. In the example below, the conditional sum 
function can determine how many people are on academic probation that transferred from 
other schools. In this example, there are two criteria that need to be defined and then a 
sum of those who meet both. 

 

To start the wizard: 

1. Click a cell within the table or list. 

2. On the Tools menu, click Conditional Sum. 

The Conditional Sum Wizard is an add-in. If the Conditional Sum command is not 
on the Tools menu, install and load the wizard. (See Add-In Commands and 
Functions, page 10.) 

3. Enter the information requested. (See the image on the next page.) Use the drop-
down menu to select available options for the Column to sum. Also use drop-down 
menus to determine the criteria for the data to sum. Click the Add Condition button 
to add criteria to the list; you can define more than one criterion. 

4. After all selections are complete, click Finish in the last dialog box.  
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The Conditional Sum Wizard 

Analyzing Data with the PivotTable 
A PivotTable is an interactive table that summarizes, or cross-tabulates, large amounts of 
data. You can “pivot” rows and columns in and out of the table to view various 
summaries of data. You can also filter data by displaying different “pages”, or by 
selecting specific areas of interest. 

The PivotTable summarizes data by using a summary function that you choose, such as 
SUM, COUNT, or AVERAGE. You can include subtotals and grand totals automatically, 
or use your own formulas by adding calculated fields and items. 

In a PivotTable, each column in your source data becomes a PivotTable field that 
summarizes multiple rows of information. For example, if we have a list of data with a 
column called Name, there would be a PivotTable field called Name that you could place 
as a row label or column label in the PivotTable. All the unique values in this Name 
column become items in the PivotTable. So if there are five rows with “John Doe” under 
the Name column, all the data from those five rows would be collapsed and summarized 
into a single PivotTable item labeled “John Doe”. 

A PivotTable wizard provides help in creating PivotTables. 

Before creating a PivotTable 
Before starting the PivotTable wizard, 

1. Your worksheet data must be organized in a list or database format. (See the Excel: 
Data Management handout.) 

2. Place your cursor inside the list.  
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3. Remove any subtotals created with the Data > Subtotals command, since grand and 
subtotals are automatically created as part of the PivotTable. (See the Excel: Data 
Management handout.) 

Creating a PivotTable 
Before beginning the PivotTable wizard, make sure you have followed the instructions 
above. 

1. Select PivotTable and PivotChart Report from the Data menu. The first step of the 
Wizard displays. 

2. Identify the location of your PivotTable data source. The default setting is an Excel 
list or database on your current worksheet. Click Next. 

3. Select the range of cells that comprise your list. If your cursor is inside the list or 
database area, Excel selects the data automatically. You can redefine the list if 
necessary by using your mouse to select the data source and then press Enter to 
return to the dialog box. 

4. Click Next. 

5. Choose whether you want the PivotTable to appear on a new worksheet or an 
existing one. 

6. Click Layout, in the bottom left corner of the wizard.  

7. A sample PivotTable layout displays. 

 

The PivotTable wizard. 

Any column labels on your list are displayed as buttons and referred to as fields. 
Each field can be placed in one of four parts of the PivotTable. 
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ROW: Any field placed in the ROW area becomes a row label. 

COLUMN: Any field placed in the COLUMN area becomes a column label. 

DATA: Any numeric field placed in the DATA area is summarized (using the 
summary function you specify, such as SUM, AVERAGE, etc.). 

PAGE: Any field you want to use as a filter is placed the PAGE area. 

8. To place a field in the pivot table, drag its name to the appropriate area.  

9. Click OK when the layout is complete. 

10. Click Finish. 

Editing the PivotTable 
You can edit and format many components of the PivotTable. To select areas of the 
PivotTable, use the following table as a guide.  

Clicking… Selects 

Row field All row labels 

Row item All item data 

Column field All column labels 

Column item All item data 

Summary label Entire table 

Grand Total label Column or row totals 

Table components and selection 

Double-click the row or column fields to display the PivotTable Field dialog box. If the 
above methods do not select, from the PivotTable toolbar (see below), click PivotTable, 
point to Select and click Enable Selection. 

PivotTable Toolbar 
When a PivotTable is displayed on a worksheet, the PivotTable toolbar automatically 
displays. Excel also displays the PivotTable Field List, which allows you to dynamically 
alter fields in your table.  
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The PivotTable toolbar and PivotTable Field List 

Click the PivotTable menu on the PivotTable toolbar and select PivotTable Wizard to 
access the original PivotTable wizard and  to access the PivotTable Field List. Both 
these can be used to change the PivotTable data display and values. 

Deleting the PivotTable 
To delete a Pivot Table, 

1. On the PivotTable menu of the PivotTable toolbar, point to Select and click Enable 
Selection. 

2. Click a cell in the PivotTable. 

3. On the PivotTable menu of the PivotTable toolbar, point to Select and click Entire 
Table. 

4. On the Edit menu, point to Clear, and then click All. When you delete a PivotTable, 
the source data is not deleted or changed. 

Array Formulas 
An array formula is a formula that performs multiple calculations and returns either a 
single result or multiple results. Array formulas act on two or more sets of values known 
as array arguments.  

Each array argument must have the same number of rows and columns. You create array 
formulas the same way that you create basic, single-value formulas, with a slight 
exception. 
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Entering an Array Formula 
To enter an array formula: 

1. Select the cell or cells that will contain the formula. 

2. Enter the formula. 

3. Press Ctrl+Shift+Enter to enter the formula within the cell. Brackets {} display 
around the entire formula, including the equal sign. 

If you want only a single result, Excel may need to perform several calculations to 
generate that result. 

Troubleshoot errors in formulas 
If you have problems when creating functions, check the following to troubleshoot your 
formulas: 

• Double-click the cell that contains the formula to edit the formula. The worksheet 
ranges and the corresponding arguments within the formula display in colors to 
clearly define your formula arguments. 

• Parentheses are part of a matching pair. When you create a formula, Excel displays 
parentheses in color as they are entered. 

• Make sure you use the correct range operator when you refer to a range of cells. 
When you refer to a range of cells, use a colon (:) to separate the reference to the first 
cell in the range and the reference to the last cell in the range. 

• Make sure you have entered all arguments that are required and not any extras. Some 
functions have required arguments.  

You can enter, or nest, no more than seven levels of functions within functions. 

• If the name of a workbook or a worksheet you refer to contains a non-alphabetic 
character, you must enclose the name within single quotation marks. 

• Make sure each external reference contains a workbook name and the path to the 
workbook. 

• Do not format numbers as you enter them in formulas. For example, even if the value 
you want to enter is “$1,000”, enter 1000 in the formula. 

Getting Additional Help 
The Help Desk provides consulting and Q&A help in a variety of ways: 

785/864-0200 
question@ku.edu 
www.ku.edu/~helpdesk 
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