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Abstract: This document introduces users to using Microsoft Excel to 
manage information in lists. This handout explains how to use 
Excel’s list, data forms, filtering, and subtotals features, as well 
as how to manage windows and link data and/or formulas. It is 
used in conjunction with the Excel: Data Management 
workshop. 
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Introduction 
Microsoft Excel has many capabilities that make it suitable for use as a data management 
tool. By entering data into a spreadsheet in a list format, users can take advantage of these 
capabilities, which include sorting, grouping, filtering, summarizing, and subtotaling. 

Objectives 
The goal of this workshop is to use the list capabilities of the Excel program. After 
today’s workshop, participants will be able to: 

• Sort a data list. 

• Filter a data list according to criteria. 

• Extract data list information. 

• Use the subtotal function. 

• Adjust the spreadsheet windows. 

Prerequisites 
It is assumed that the participants in this workshop have either taken the Excel: 
Introduction workshop or have equivalent skills. 

Related Training Available from Instructional Services 
All workshops offered by Instructional Services are free to KU students, staff, faculty, 
and approved affiliates. 

To learn more about or register for workshops, receive automatic announcements of 
upcoming workshops, and track workshops you’ve registered for and have attended, visit 
www.lib.ku.edu/instruction/workshops. For further workshop related questions, please 
email training@ku.edu. 

Using Excel lists 
An Excel list provides features designed to make it easy to manage and analyze groups of 
related data in a worksheet. Essentially a basic database, an Excel list may be used to: 

• Search or query to find specific data 

• Sort data alphabetically and numerically by rows or columns in ascending or 
descending order 

• Extract subsets of the data based on defined criteria 

• Perform statistical calculations on the data for analysis and decision-making 

• Print data organized for specific purposes 
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Creating a List 

Set Up the List Data 
After deciding on the design for a list, set up the list by entering the data according to the 
following guidelines: 

List size: A list can be as large as an entire worksheet, but it is best to put only one list on 
a worksheet. In addition, make sure that there is a blank column and blank row between 
the list and any other data on the worksheet. (This is not absolutely necessary, but allows 
Excel to select the list automatically when appropriate.) The list itself should not contain 
blank rows or columns. 

Header row: The top row of the list should consist of headers, names for the columns in 
the list. A header may contain a maximum of 255 characters. Each header should be 
unique. 

Capitalization: Use either uppercase or lowercase letters. Excel ignores capitalization 
when searching a list. 

Formulas: Data in list columns may include formulas that calculate values from others in 
the list. 

Make it an Excel List 
1. Click any cell in the list. 

2. Click the Data menu, point to List, and click Create List. 

 

The Create List dialog box 

3. Confirm that the range reference indicated in the Create List window is correct, 
and that the My list has headers checkbox is checked if your data has a header 
row (as recommended above), or cleared if it does not. 

4. Click OK. 

 

An Excel list 
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The range of cells designated as a list gains a number of features: 

• A dark blue border outlines the list. 

• AutoFilter buttons appear in every column in the list (in the header row), 
enabling you to quickly sort or filter your data. (See AutoFilter, page 9.) 

• The insert row, denoted by the asterisk, is added. Typing information in this row 
adds data to the list, and the list will automatically resize to accommodate it. 

• The resize handle, in the lower right corner of the border, can be dragged to 
modify the size of the list. 

In addition, the List toolbar appears. 

 

The List toolbar 

Sorting 
After a list is created, Excel can organize or format the information quickly. Sorting 
organizes the data in a list alphabetically, numerically, chronologically or in any order 
you want. Sorting rearranges the rows according to the contents of the column by which 
the sort is performed. It is also possible to sort multiple fields as well as data within a 
single column. 

Note: If you sort data within a single column, it only sorts the data in that column. 
It will not rearrange the rows. This may have undesirable effects. 

To perform a Simple Sort 
There are several ways to sort the entire list by a single column. Here are two of the 
simplest. 

Using the Standard Toolbar 
1. Click any cell in the column by which you want to sort. 

2. Click either the Sort Ascending button or the Sort Descending button in the 
Standard toolbar. 

 

The Sort Ascending and Sort Descending toolbar buttons 

Using the AutoFilter Buttons 
1. Click the AutoFilter button in the header of the column by which you want to 

sort. 

 

An AutoFilter button 
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2. Click either Sort Ascending or Sort Descending at the top of the scrolling 
menu. 

To Sort by Multiple Columns 
1. Select a single cell in the list. 

2. Click the Data menu and choose Sort 
or 
click List on the List toolbar and choose Sort. 

 

Multiple column sort 

3. Click the down arrow next to the Sort by input box to choose the primary sort 
column.  

4. Next select whether the sort should be ascending or descending by clicking the 
radio buttons to the right of the column selection.  

5. Repeat steps #3 and #4, using the Then by boxes to define secondary and tertiary 
sort criteria if necessary.  

6. Click OK. 

Data Forms 
Excel has a built in form feature that enables you to input data into a list. The data form 
displays all of your column labels in a single dialog box, with a blank space beside each 
label for you to fill in data for a new column. You can enter new data, find rows based on 
cell contents, update existing data, and delete rows from the list. 

A data form can make data entry easier than typing across the columns when you have a 
wide list with more columns than will fit on the screen at one time, or when a list is so 
long that you have to scroll down to access the insert row. 
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Adding Data Using the Data Form 
To add records using the Form, you can do the following: 

1. Click somewhere within your data list. 

2. Click the Data menu and choose Form. 

 

A data form 

3. A data form will open and you’ll see the first row, or record, from your list in the 
form. 

4. To add a record to the list, click the New button and enter the information. 

5. To move from field to field, press the Tab key. 

6. Once you’ve finished entering the new record, you can press Enter to enter another 
new record or you can click the Close button to close the form. 

Note: The Delete button will permanently delete the record that is displayed 
in the form. If you click this button, you will not be able to use Undo 
to retrieve the record. 

The Restore button restores all the fields to blank if you are entering a 
record and decide you don’t want it. It will also restore an existing 
record if you changed the record information, but have not moved off 
the record. 

If you have fields that are based on formulas, such as a Total column, 
you will not be able to enter any data into that field in the form. It will 
appear grayed out. 
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Finding Records Using Criteria 
You can also use the data form to find records that meet certain criteria. For instance, you 
could find all employees that contribute at least $2000 a year to their retirement plan. 

1. Click anywhere in your list. 

2. Click the Data menu and click Form. 

3. Click the Criteria button. 

4. When you do this, all of the fields will become blank and the word Criteria will 
appear above the New button. 

5. Enter the comparison criteria into the form. 

6. Click the Find Next button to find the first record that meets your criteria. Continue 
to click Find Next until you have found the record(s) you want. 

Note: You can also use the Find Previous button if you want to go back up your 
list. 

You cannot use this form to modify existing records when using the criteria 
feature. 

Types of Criteria 
Criteria can be a string of characters that you want to match or an expression involving a 
comparison operator. Here are the different operators you can use and what they mean: 

Operator Meaning 

> Greater than 

< Less than 

>= Greater than or equal to 

<= Less than or equal to 

* Wildcard takes the place of as many characters as needed 

If you enter criteria into more than one field, Excel will use an implied and, which means 
that the record must meet all of the criteria to be shown. 

Click the Form button to return to the display of all records. 

Filtering Data 
One way of showing data from a list that meets certain conditions is by using filters. 
Filtering extracts data from the list by identifying the subset of the data that satisfies the 
criteria you choose. There are two ways to filter data in Excel, AutoFilter and Advanced 
Filter. 
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AutoFilter 
A quick way to filter data in a list is by using AutoFilter. This filter automatically 
provides certain criteria that can be used to extract a subset of data.  

AutoFilter is automatically enabled for Excel lists (see Creating a List, page 4). 
(Otherwise, it can be enabled by clicking the Data menu, pointing to Filter, and clicking 
AutoFilter.) 

 

An AutoFilter button 

To filter the list, click an AutoFilter button and choose a value from the scrolling menu. 
Only rows having the selected value in the filter column will be displayed. The arrow in 
the AutoFilter button for the column you chose and the numbers of the rows will both 
turn blue to indicate that what you’re seeing is a filtered subset of the list. 

You can select other criteria from the AutoFilter buttons of other columns. Continuing to 
do this creates an “and” condition, meaning that, in order for a row to show, it must meet 
the criteria for all of the columns in which you applied a filter. 

To display all of your data again, click the AutoFilter button of the column you had set 
criteria for and choose (All). If you chose more than one criterion, you can click the Data 
menu, point to Filter, and choose Show All. 

Advanced Filters 
Sometimes you might find the need to create more specialized filters that use the 
operators “or” or “and” and look for multiple criteria from several columns. Advanced 
Filters can help you accomplish this. To create this type of filter, you have to do two 
things: (1) set up the criteria and (2) execute the filter. 

Setting up the Criteria 
The first thing to do before filtering a list of data is to set up the criteria range, a range of 
cells outside your list that specifies the comparison criteria. The criteria range consists of 
at least two things: 

• Duplicates of the list column name(s) on which you’re imposing restrictions 
(criteria). 

• The criteria that must be met in order for the row not to be filtered out. 

There are different types of criteria that you can use for filters, and you can always use 
more than one column and criterion. The following lists several examples and shows 
different ways of setting up the criteria in your worksheet. 
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Criteria with Operators 
There are many different operators you can use when creating criteria, such as greater 
than (>), less than (<), greater than or equal to (>=), less than or equal to (<=), and any 
combination of those. In this example, not only are operators being used, but the implied 
and operator is also used because all of the criteria appear on the same row. 

 

And 
Sometimes you might find you need to find records that meet more than one criterion. 
Anytime you place criteria on the same row, Excel uses the implied and operator. The 
picture shown above represents the use of and. In order not to be filtered out by these 
criteria, records must be of Genre “Action” and must have a Runtime value between 90 
and 120 (i.e., greater than 90 and less than 120). 

The following criteria also use and. Records must be of Genre “Comedy” and must have 
an “R” Rating.  

 

Or 
Another option is to search for records that meet any of multiple criteria that you choose. 
This is useful when you want to search for multiple records that don’t necessarily have to 
meet the same criteria. We can modify the previous example to use an or instead of an 
and. 

 

Notice that while the criteria and column names remained the same, the way in which the 
criteria were created was changed. Instead of the criteria being on the same row, the 
criteria were placed on different rows. This informs Excel that records should not be 
filtered out if they are of Genre “Comedy” or have an “R” Rating.  

Complex Criteria 
There might be times when you need to use both and and or combinations in your criteria 
range. For example, we may wish to see Westerns that are shorter than 90 minutes and 
Dramas that are shorter than 2 hours. In our criteria range, that would look like this: 

 

We can interpret this as follows: in order for a record not to be filtered out, it must be (1) 
a Western shorter than 90 minutes or (2) a Drama shorter than 120 minutes.  
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Executing the Filter 
Once you’ve set up the criteria range, you’re now ready to execute the filter. 

 

The Advanced Filter dialog box 

1. Click anywhere in your list. Click the Data menu, point to Filter, and choose 
Advanced Filter. 

a. List range: This is the list and will appear as an absolute reference. 

b. Criteria range: This is the criteria range that you set up before going through the 
advanced filter. To specify the criteria range, first click in the Criteria range 
field, then select the range in the worksheet that contains the criteria. This range 
will appear as an absolute reference.  

c. Action: The default action is to filter the list in place. You can instead choose to 
copy the list to a different location. If you choose this option, you’ll need to click 
in the Copy to field, then click on the cell within the same worksheet where you 
want the information to start. 

Note: If you choose to copy the filtered list to a different location, it must be in the 
same worksheet that the original list is in. You cannot copy the filtered list to 
a different worksheet. 

2. Click OK. 

If you chose to filter the list in place, any rows that don’t meet the criteria you specified 
will be hidden. The number(s) of the row(s) that does (do) meet the criteria will turn blue. 

If you chose to copy the rows that meet the criteria to another location, each that meets 
the criteria you set will be copied. 

If you filtered in place and want to return to the original list, click the Data menu, point 
to Filter, and choose Show All. If you copied the filtered list, simply delete the range that 
contains the records. 
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Special Features for Filtered Lists 
There are many different reasons to filter a list of data. Here are just a few: 

• Charting only data that meets certain criteria. 

• Using functions, such as AutoSum, or other types of calculations. 

• Printing only filtered data. 

• Formatting only data that meets certain criteria. 

• Deleting only those records. 

Totals and Subtotals 

Total Row 
Click the Toggle Total Row button in the List toolbar (or click the Data menu, point to 
List, and click Total Row), and a total row is added to the bottom of your list. 

 

The Toggle Total Row button 

If the rightmost column contains numeric data, Excel automatically adds the data in that 
column. You can click any cell within the total row to Sum its column—or choose 
instead to display any of a number of other aggregate functions, including: 

• Average: the average of the values 

• Count: the number of data values 

• Count Nums: the number of data values that are numbers 

• Max: the largest value 

• Min: the smallest value 

• StdDev: an estimate of the standard of deviation of a population, where the 
sample is a subset of the entire population 

• Var: an estimate of the variance of a population, where the population is all of 
the data to be summarized 

Just pick the function you want from the drop-down list that appears when you click the 
total row cell. (You can choose None if you don’t want any aggregate value for a 
column.) 

Subtotals 
Excel’s Subtotals feature quickly summarizes data within a list. Based upon the data you 
select, Excel can automatically calculate both subtotals and grand totals. Subtotals are 
based on organized, sorted groups of data. 
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Note: Unfortunately, the Subtotals feature does not work with formally designated 
lists (those marked with a blue border). Before applying the Subtotals 
feature to an Excel list, you must first convert it to an ordinary range by 
clicking the Data menu, pointing to List, and clicking Convert to Range. 

Doing so will: 

• remove the blue border 

• enable the Subtotals feature 

• disable the insert row 

• disable the total row 

Organizing Data for Subtotals 
Before using subtotals, the data to analyze must be sorted in some fashion (see Sorting, 
page 5). This is necessary because the subtotals feature of Excel calculates summary data 
(i.e., subtotals) based on groups of contiguous rows. By sorting, we create these groups in 
our list. For example, consider a list of employees where each employee record has a 
Department field and a Retirement Plan field. If you want to know how many 
employees are in each department, you prepare for using subtotals by sorting by the 
Department field to group the departments together. Once you’ve sorted the information 
and groups are formed, you’re ready to use the subtotal feature to count the number of 
employees in each group (in this case, department). 

When you create your primary subtotal, the sort column you specify as your primary sort 
must be the column on which you want to base your subtotals.  

Note: That does not mean the subtotal must be added to that column. It means that 
for the At each change in: field, you must use the column name that you 
sorted by. 

Using the above example, the column to which you would apply the subtotal would be 
the Department column. The number of times the department name appears would tell 
you how many people work in each department. The calculation that is to be performed is 
one of counting, and because of this, you would use the Count function. 

If you want to subtotal more than one column, use the second and third level sort options 
to organize the list into secondary and tertiary groups.  

Using the above example, you could count not only how many people are in each 
department, but also how many people in a particular department use a specific 
retirement plan. To do this, you would set the primary sort on Department with a 
secondary sort on Retirement Plan before using the subtotal feature. The first subtotal 
would be based on the Department field. The second subtotal would be based on the 
Retirement Plan field, and would not replace the first one. 
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Displaying a Subtotal 
Once you’ve organized your data by at least a primary sort, you’re ready to use Excel’s 
subtotal feature.  

1. Select a cell within your list. 

2. Click the Data menu, point to List, and click Convert to Range. (See the note on 
page 13.) 

3. Click the Data menu and click Subtotals. 

 

The Subtotal dialog box 

4. In the At each change in field, click on the drop down arrow and select the field that 
is your primary sort. 

5. In the Use function field, click on the drop down arrow and choose which function 
you want to use. This is the summary function you’d like to calculate on your data. 

6. To determine which values to calculate using the function you selected, check one or 
more fields in the Add subtotal to field. 

7. By default, Replace current subtotals and Summary below data are checked. If 
you want the summary (total for each group) to appear first and the details for each 
record appear next, uncheck the Summary below data box. If want to print each 
group on a separate page, check Page break between groups. 

8. Once you’ve selected your options, click OK. 

Nested Subtotals 
You can have multiple levels of subtotals, subtotals for smaller groups, within your 
primary (original) subtotals groups. If you want another subtotal inside of the one you 
just did, go back through steps #3 through #7, but for the At each change in field, choose 
the secondary sorted field. Also, make sure that you uncheck Replace current subtotals 
so it doesn’t replace the one you previously did. These are called nested subtotals. 
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An example of nested subtotals 

Using More Than One Summary Function on a Column 
You can calculate the values within a column using more than one function. For example, 
you may want to sum a column and also count the number of values in that same column.  

To use more than one summary function on one column, 

1. Click the Data menu and click Subtotals. 

2. Select the first function in the Use function field. 

3. Click OK.  

4. Click the Data menu again and click Subtotals. 

5. Select another function in the Use function field. 

6. Clear the Replace current subtotals check box. 

7. Click OK. 

You can repeat this procedure to calculate using additional functions. 

Subtotal Outlines 
When you subtotal, rows are added to display the subtotals, and the data list is organized 
in outline format. At the top left, level markers allow you to quickly collapse all items at 
or below a given level At the left, outline markers allow you to expand (+) and collapse 
(-) individual groups. 
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Expanded and collapsed subtotal outline groups 

• To expand individual groups, click the plus sign (+) for the group at the left of the 
spreadsheet window. 

• To collapse individual groups click the minus sign (-) for the group at the left of the 
spreadsheet window. 

• To display only the grand totals, click the 1 at the top left of the spreadsheet window. 

• To display all levels of the outline, click the largest number at the top left of the 
spreadsheet window. 

• To display only subtotals of the outline, click the 2 (or additional numbers) at the top 
left of the spreadsheet window. 

Removing Subtotals 
To remove subtotals from your list: 

1. Click on the Data menu and click Subtotals. 

2. Click the Remove All button. 

Managing Windows 

Multiple Windows 
Every document is viewed in a window. There can be many windows for the same 
document open on the screen or there can be one window for each of several documents 
opened at the same time. When working with a list and using the Advanced Filter, it 
may be convenient to view the criteria in one window and the list in another. 
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To open another window for the same document: 

1. Make sure that the window for the worksheet is active. 

2. From the Window menu, choose New Window. Excel uses the same worksheet 
name for both the windows but adds a number to the name. 

To activate a window, click anywhere in the window. All the windows that are currently 
available are listed in the Window menu. Choosing any of these names can also activate 
the window. 

To move a window, drag it by its title bar.  

Note: If the document title bar is not visible, click the Restore Window  button 
by the menu bar to create a moveable window. 

Splitting Windows 
Rather than creating another window and scrolling each independently, a single window 
can be split into panes by dragging either of the split bars to another location. Split bars 
are located directly above the up arrow button on the vertical scroll bar, and directly right 
of the right arrow button on the horizontal scroll bar. After splitting a window, its pane 
size may be changed by dragging the split bar. 

 

A horizontal split bar 

Remove a horizontal split by dragging the split bar to the top or bottom edge of the 
window. Remove a vertical split by dragging the split bar to the left or right edge of the 
window. 
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Freezing Panes 
You can also lock cells so that they never scroll out of view by freezing panes. For 
example, you could freeze the header row of your list to keep it visible as you scroll. 

1. To lock rows, select the row below where you want the split to appear.  

To lock columns, select the column to the right of where you want the split to 
appear. 

To lock both rows and columns, click the cell below and to the right of where 
you want the split to appear. 

2. On the Window menu, click Freeze Panes.  

To unlock cells, click Unfreeze Panes on the Window menu. 

Linking Data 
If you want to link one cell or range to another between worksheets, one way to do this is 
by using the Paste Special dialog box. 

1. Select the data you want to copy. 

2. Use any of the available methods to copy the data to the clipboard (e.g., Copy 
command on the Edit menu, Copy button on the Standard toolbar, Ctrl-C 
keystroke).  

3. Access the worksheet where you want to link to the data and select the appropriate 
cell.  

4. Click the Edit menu and click Paste Special. 

5. Click the Paste Link button in the Paste Special dialog box that appears.  

6. The worksheet displays the value of the copied cell or range. Note however the 
formula in the formula bar: it displays the 3-D reference to the copied cell or range. 

Note: Linked cells are updated when the workbook that contains the linked cell is 
opened. 

Getting Additional Help 
The Help Desk provides consulting and Q&A help in a variety of ways: 

785/864-0200 
question@ku.edu 
www.ku.edu/~helpdesk 

Last Update: 01/29/2006 


