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Abstract: Take control of your Web site with Dreamweaver’s powerful 
site management tools.  In this class we will focus on using 
libraries and templates. 
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Introduction 

As you develop websites, you accumulate a growing number of assets. In some cases, 
you might use the same assets across multiple sites.  In this workshop we will focus on 
two assets: library items and templates. Library items and templates are linked assets, 
which means that editing a library item or template will update all documents in which 
these assets have been applied. Library items are intended for individual design elements, 
such as a site’s copyright information or a logo. Templates let you control a larger design 
area. 

Additionally, Dreamweaver provides several features to help you test your site, including 
previewing pages and checking for browser compatibility. You can also run various 
reports, such as a broken links report. 

Objectives 
In this workshop you will learn how to: 

• Use libraries to manage similar content among various pages 

• Create templates to give a Web site a uniform look and feel 

• Use built in utilities such as Check Links to quickly locate and manage broken 
links and dead pages 

Prerequisites 
• Dreamweaver:  Getting Started 

• Dreamweaver:  Creating Web Pages 

Definitions 
Term Definition 

Asset Assets include a variety of elements that you store in a site, such as an image or 
movie file. You can view and manage assets in the current site using the Assets 
panel. 

CSS 
(Cascading 
Style Sheet) 

Cascading Style Sheets (CSS) are collections of formatting rules that control the 
appearance of web pages. 

Dependent 
file 

Dependent files are images, external style sheets, libraries, and other files 
referenced in your document that a browser loads when it loads the document. 

Editable 
Region 

An unlocked region in a template-based document; a section a template user can 
edit. 
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Library A library contains a collection of individual assets or copies of assets you have 
created for placement in your web pages.  A change or update to a library item 
updates each of the web pages on which that item appears. 

Place Holder A placeholder is a spot or location you use in a Dreamweaver document until 
final artwork is ready to be added to the page. You can define certain attributes 
of the placeholder: you can set the placeholder’s size and color, as well as 
provide it with a text label. An image placeholder’s color, size attributes, and 
label appear when the image placeholder is viewed in the Document window. 

Template A “fixed” page layout. The author creates regions in the template that are 
editable in documents based on that template; if the author does not define a 
region as editable, then template users cannot edit content in that area. 
Templates enable template authors to control which page elements template 
users—such as writers, graphic artists, or other web developers—can edit. 
There are several types of template regions the template author can include in a 
document. 

One of the most powerful uses of templates is the ability to update multiple 
pages at once. A document that is created from a template remains connected to 
that template (unless you detach the document later). You can modify a 
template and immediately update the design in all documents based on it. 
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Assets Panel 
You can use the Assets panel to view and 
manage assets in your current site.  The 
Assets panel displays assets for the site 
associated with the active document in the 
Document window.  Assets include a variety 
of elements that you store in a site, such as 
an images or movie files.   

Note: You must define a local site 
before you can view assets in the 
Assets panel. 

The Site list shows all of the assets in your 
site, including colors and URLs that are 
used in any document in your site. 

The Favorites list shows only the assets you 
have explicitly chosen.  To add an asset to 
the Favorites list, select the asset in the Site 
list, then select Add to Favorites from the Options menu in the Files panel group’s title 
bar. 

QuickTime™ and a
TIFF (Uncompressed) decompressor

are needed to see this picture.  

In both lists, assets are divided into categories (along the left side of the Assets panel).  
The Site list and the Favorites list are both available for all categories of assets except 
templates and library items. 

Opening the Assets Panel 
In the Files panel group, click the Assets tab (or choose Window > Assets from the 
menu bar). 

The Assets panel appears.  By default, the Images category is selected. 

To preview an asset, select the asset.  The preview area at the top of the panel shows a 
visual preview of the asset. 

To change the size of the preview area, drag the line that separates the preview area from 
the asset column headings. 

What are Libraries? 
Libraries contain page content such as images, text, Flash files and other objects that you 
want to reuse or update frequently throughout your web site. When you place a library 
item in a document, Dreamweaver inserts a copy of the HTML source code for that item 
into the document, and adds an HTML comment containing a reference to the original, 
external item. The reference to the external library item makes it possible to update the 
content on an entire site all at once by changing the library item. 

Dreamweaver stores library items in a Library folder within the local root folder for each 
site. Each site has its own library. 
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Note: There are special requirements for editing behaviors in library items.  
Reference the Dreamweaver Help for more information. 

Library items cannot contain style sheets, because the code for those 
elements is part of the head section. 

Creating a Library Item 
You can select any portion of a document to have Dreamweaver convert into a library 
item.  Library items can include any normal HTML element, including text, tables, forms, 
navigation bars, and images, just to mention a few. Dreamweaver stores only a reference 
to linked items such as images. The original file referenced must remain at the specified 
location for the library item to work correctly. 

1. To create a library item, select a portion of a document to save as a library item. 

2. In the Files panel group, click the Assets tab (or choose Window > Assets from the 
menu bar) to reveal the Assets panel. 

3. Click the Library  icon to show the Library Panel. 

 
The Library in the Assets Panel 

4. To add new content to a new library item: 

a) Click the New Library Item  icon at the bottom of the Assets panel.  A new 
untitled library item appears. 

b) Name the library item and press [Enter]. 

c) Double-click the top area of the Assets panel to create new content. 

5. To add content from an existing web page: 
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a) Click and drag content from the web page to the Assets panel showing the 
Library category. 

b) Name the library item. 

 

 
Naming a library item 

Dreamweaver saves each library item as a separate file, with the filename extension .lbl, 
in the Library folder of the site’s local root folder. 

Setting Library Preferences 
You can customize the highlight color for library items or hide them altogether. 

Changing the Highlight Color for Library Items 
1. Choose Edit > Preferences (Windows) or Dreamweaver > Preferences (Mac).  The 

Preferences dialog box appears. 

2. Select Highlighting under the Category column. 

3. In the Library items field, click the color box to select a color for the library items. 

4. Click OK to close the Preferences dialog box. 

5. View >Visual Aids > Invisible Elements must be on for the library highlight color 
to be visible in the Document window. 

Adding a Library Item to a Page 
When you add a library item to a page, the actual content is inserted in the document 
along with a reference to the original item. After the content has been inserted, the 
original item does not have to be present for the content to be displayed. 

1. Click in the Document window at the point at which you want to insert the library 
item. 

2. In the Assets panel, select the Library category and do one of the following: 
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• Drag a library item from the Assets panel to the Document window 

 
or  

• Select a library item and click Insert on the bottom of the Assets panel. 

Tip: To insert the contents of a library item without including a reference to the item 
in the document, press [Ctrl] while dragging an item out of the Assets panel. If 
you insert an item this way, you can edit the item in the document, but the 
document won’t update when you update pages that use that library item. 

Making Changes to a Library Item 
When you change a library item, you can choose to update all documents that use that 
item. If you choose not to update, the documents remain associated with the library item; 
you can update them later by choosing Modify > Library > Update Pages.  

Other kinds of changes to library items include renaming items to break their connection 
with documents or templates, deleting items from the site’s library, and recreating a 
missing library item.  

1. To edit a library item, choose Window > Assets and select the Library category. 

2. Do one of the following: 

• Select a library item and click the Edit icon at the bottom of the panel. 
QuickTime™ and a

TIFF (Uncompressed) decompressor  are needed to see this picture.

• Double-click the library item.  

3. Dreamweaver opens a new window for editing the library item.  Edit the library item 
and save your changes. 
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4. In the dialog box that appears, choose whether to update the documents on the local 
site with the edited library item: 

• Choose Update to update all documents in the local site with the edited 
library item. 

• Choose Don’t Update to avoid changing any documents until you use 
Modify > Library > Update Current Page or Update Pages. 

Updating Pages that Use an Edited Library Item  
1. Choose Modify > Library > Update Pages.  The Update Pages dialog box appears. 

2. Choose the files that you want to update. 

• Choose Entire Site to update all documents on the specified site. 

• Choose Files That Use to update all documents that use the specified library 
item. 

3. Library Items should be selected in the Updated field. 

4. Click Start. The content of the library item is replaced in the specified documents. 

Renaming a Library Item 
1. Select a library item in the Assets panel. 

2. Click inside the item name and type a new name. 

3. When you press [Enter], Dreamweaver asks if you want to update files that use the 
item. 

• If you click Update, all documents that previously used the item will update their 
references to the new name. 

• If you click Don’t Update, documents that have references to the item under its 
old name will not automatically update their references to the new name. 

Deleting a Library Item from the Library 
1. Select a library item in the Assets panel. 

2. Click the trash icon or press [Delete].  

Caution: Be careful; if you delete a library item, you cannot use Undo to 
retrieve it. 

Deleting a library item removes the item from the library, but doesn’t change the contents 
of any documents that use the item. 

Making Library Items Editable  
If you’ve added a library item to your document and you want to edit the item 
specifically for that page, you must break the link between the item in the document and 
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the item in the library. Once you’ve made an instance of a library item editable, that 
instance cannot be updated from the library.  

1. To make a library item editable, select a library item in the current document. 

2. Click the  button in the Property inspector. 

Using Templates 
Templates are special files you can create in Dreamweaver that provide pre-made layouts 
for new or existing documents on your web site. Pages you create from Templates have 
editable regions where you place the page’s contents. Other regions of the web page, such 
as navigation areas, footers and graphics, cannot be edited. Instead, these regions can 
only be updated by changing the template. 

Creating a Template 
Begin with (or create) a working web page in Dreamweaver. This page should have the 
basic layout and formatting you want to apply to all the pages based on this soon-to-be 
template. The content you put on this page will not be editable in pages based on this 
template.  It will only be editable in the template itself. 

1. To save the page as a template, click the File menu and click Save as Template.  The 
Save As Template dialog box appears. 

 
2. Templates are associated with site definitions. You will need to save your Template 

to a particular site (the current site will be selected), and choose a name for your 
template. Your site may have more than one template associated with it. 

3. Click Save. 

Once saved, your template will be stored with your other site files in a separate folder 
called Templates; the file will have a .dwt filename extension. 

Creating Editable Regions 
Dreamweaver automatically locks most regions of a document when you save it as a 
template.  You can specify which regions of a template-based document will be editable 
by inserting editable regions in the template. 
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1. With your template file open, highlight an area on the page that will be editable, such 
as a main heading or body content. 

2. Click the Insert menu, choose Template Objects, and choose one of the following: 

 

 
The Template Objects sub-menu 

• Editable Region: This is an unlocked region of the template.  An effective 
Template should contain at least one editable region; otherwise, pages based on 
the template can’t be edited. Selecting this will delete the existing content on the 
page, and replace it with a placeholder with the name of the editable region. This 
option works best for single-element items, such as headings. 

• Optional Region: You use the Optional Region dialog box to create template 
parameters and to define conditional statements (If...else statements) for template 
regions. You can use simple true/false operations, or define more complex 
conditional statements and expressions. 

• Repeating Region: A repeating region is a section of a template that can be 
duplicated as often as desired in a template-based page. Repeating regions are 
typically used with tables; however, you can define a repeating region for other 
page elements as well.  Usually repeating sections are editable. 

3. Once you’ve selected the type of region the New Editable Region dialog appears.  
Type a name for the region in the Name field. 
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4. Click OK to save your changes. 

Creating new Web Pages using a Template 
1. Choose New from Template from the File menu. 

2. Select your template from the list, then click Select. 

3. In the newly created document, enter new text in the editable regions. 

4. Save the file. 

Applying a Template to an Existing Web Page 
1. Open the web page in a new Document window. 

2. Choose Modify > Templates > Apply Template to Page.  The Select Template 
dialog box appears.  

 
3. Choose the template you want to apply to this page and click Select. 

4. The existing content of the page may need to be placed into one of the named 
editable regions of the template. Dreamweaver will then prompt you to choose the 
region where you want to place the page content. Choose the following from the 
Inconsistent Region Names dialog box. 

• From the Name column, choose the region from the documents you want to 
match to an editable region in the template (i.e. Document body). 

• In the Move Content to New Region drop down list, choose the region in 
which you want to place the corresponding content. 
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5. The template is applied to the page and the existing content appears in the area you 

selected. 

6. Close and save the file. 

Once you have created templates for your site, you can open your template files to update 
and change the layout of your site, and have those changes apply to all pages created 
from the template. 

Testing Your Site  
Dreamweaver provides several features to help you test your site, including previewing 
pages and checking for browser compatibility. You can also run various reports, such as a 
broken links report. 

Checking for Broken, External, and Orphaned Links 
Use the Check Links feature to search for broken links and unreferenced—also known as 
orphaned—files (files that still exist in the site but no other files in the site link to) in an 
open file, a portion of a local site, or an entire local site.  

The only links that Dreamweaver verifies are links to documents within the site; 
Dreamweaver compiles a list of external links that appear in the selected document or 
documents, but does not verify them. 

You can also identify and delete files that are no longer used by other files in your site.  

To Check Links within the Current Document 
1. Save the file to a location within your local Dreamweaver site.  
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2. Select File > Check Page > Check Links.  The Broken Links report appears in the 
Link Checker panel (in the Results panel group), showing local links that appear in 
the document for which corresponding files cannot be found in the site. 

3. Select External Links from the Show pop-up menu to view a list of external links 
that appear in the document. 

Tip: You can check for orphaned files when you check links across an 
entire site (see To check links in the entire site, below). 

4. To save the report, click the Save Report button  on the left side the Link 
Checker panel.  

To Check Links within a Portion of a Local Site 
1. In the Files panel, select a site from the Current Sites pop-up menu.  

2. In Local view, select the files or folders to check.  

3. Select File > Check Page > Check Links. The Broken Links report appears in the 
Link Checker panel (in the Results panel group), showing local links that appear in 
the document for which corresponding files cannot be found in the site. 

4. Select External Links from the Show pop-up menu to view a list of external links 
that appear in the document. 

Tip: You can check for orphaned files when you check links across an 
entire site (see To check links in the entire site, below). 

5. To save the report, click the Save Report button  on the left side the Link 
Checker panel.  

To Check Links in the Entire Site 
1. In the Files panel, select a site from the Current Sites pop-up menu.  

2. Select Site > Check Links Sitewide. The Broken Links report appears in the Link 
Checker panel (in the Results panel group), showing local links that appear in the 
document for which corresponding files cannot be found in the site. 

3. Select External Links from the Show pop-up menu to view a list of external links 
that appear in the document. Select Orphaned Files to show site files with no 
incoming links. This means that no files in your site link to these files. This can be 
useful for identifying and deleting unused files. 

Note: If you select Orphaned Files as your report type, you can delete 
orphaned files from the Link Checker panel directly by selecting a file 
from the list and pressing the Delete key. 

4. To save the report, click the Save Report button  on the left side the Link 
Checker panel.  
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To Run Reports to Test a Site  
1. Select Site > Reports.  The Reports dialog box appears. 

2. Select a category to report on and a report type to run.  Click Run to create the 
report.  

Depending on the type of report you run, you might be prompted to save your file, 
define your site, or select a folder (if you haven’t already done so). 

A list of results appears in the Site Reports panel (in the Results panel group). 

Tip: If you want to run only an accessibility report for your site, you can 
select File > Check Page > Check Accessibility.  To learn more 
about accessibility, attend the Web Accessibility workshop 
(www.lib.ku.edu/instruction/workshop.cfm?id=38). 

To Use and Save a Report 
1. Run a report (see the previous procedure, To run reports to test a site).  

2. In the Site Reports panel, do any of the following to view the report:  

• Click the column heading you want to sort results by.  You can sort by filename, 
line number, or description.  You can also run several different reports and keep 
the different reports open. 

• Select any line in the report, then click the More Info button  on the left side 
of the Site Reports panel for an description of the problem.  The information 
appears in the Reference panel. 

• Double-click any line in the report to view the corresponding code in the 
Document window. 

Note: If you are in Design view, Dreamweaver changes the display to split 
view to show the reported problem in code. 

3. click the Save Report button  on the left side the Site Reports panel to save the 
report.  

When you save a report, you can import it into an existing template file. You can 
then import the file into a database or spreadsheet and print it, or use the file to 
display the report on a website. 

Searching for and Replacing Text 
You can use the Find and Replace command to search for text and for HTML tags and 
attributes in a document or a set of documents. 

To search for text and HTML within documents: 

1. Open the document to search in, or select documents or a folder in the Files panel. 

2. Select Edit > Find and Replace. 

The Find and Replace dialog box appears. 
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3. Specify which files to search in using the Find in pop-up menu. 

4. Use the Search pop-up menu to specify the kind of search you want to perform: 

• Source Code lets you search for specific text strings in the HTML source code. 
You can search for specific tags using this option, but the Specific Tag search 
provides a more flexible approach to searching for tags. 

• Text lets you search for specific text strings in the text of the document. A text 
search ignores any HTML that interrupts the string. For example, a search for 
the black dog would match both the black dog and the 
<em>black</em> dog. 

• Text (Advanced) lets you search for specific text strings that are either within or 
not within a tag or tags. For example, in a document that contains the following 
HTML, searching for tries and specifying Not Inside Tag and the em tag 
would find only the second instance of the word tries: John 
<em>tries</em> to get his work done on time, but he doesn't 
always succeed. He tries very hard. See “Setting the Find and 
Replace dialog box options for an advanced text search” in Dreamweaver Help 
for details. 

• Specific Tag lets you search for specific tags, attributes, and attribute values, 
such as all img tags with align set to left. See “Setting the Find and Replace 
dialog box options for a specific tag search” in Dreamweaver Help for more 
information. 

5. Specify the text or tags to search for. 

6. Optionally, specify replacement text. 

7. Use the Options to expand or limit the search, if desired. See “Setting the Find and 
Replace dialog box options” in Dreamweaver Help for details. 

8. To search without replacing, click the Find Next or Find All button. To replace 
found text or tags, click the Replace or Replace All button. 

9. When you’re done, click the Close button to close the dialog box. 
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Related Training Available from Information Technology 
All workshops offered by Information Technology are free to KU students, staff, faculty, 
and approved affiliates. 

To learn more about or register for workshops, receive automatic announcements of 
upcoming workshops, and track workshops you’ve registered for and have attended, visit 
www.infotraining.ku.edu. For further workshop related questions, please email 
training@ku.edu. 

Getting Additional Help 
IT Customer Service Center staff are available for computing assistance seven days a 
week. Call, email, or stop by in person at the Computer Center to get help. 

(785) 864-8080 
itcsc@ku.edu 
www.technology.ku.edu/~helpdesk 

Last Update: 03/22/2010 

http://www.hreo.ku.edu/policies_procedures/category_details/13
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